Sign in with
Sign up | Sign in
Your question

Local area connection doesn't have a valid ip configuration

Last response: in Networking
Share
February 2, 2011 8:06:07 PM

I have been trying to solve this for 2 days straight. After searching multiple forums and trying a bunch of things I am no closer to a solution. Here's what I've already systematically tried with no joy. This is not exactly the order in which I tried them, more as I remember what I did to attempt a fix:

1. Checked the cable, it's seated well in socket and even tried a new cable. Same problem.
2. Swapped in a new NIC that was working in another computer. Tried the old NIC in that other computer, it was fine, so I put it back, since that is not the problem.
3. Updated Network Controller drivers. Rolled back drivers. Let Windows 7 find its own drivers. None of those actions helped.
4. Removed the Bonjour Service.
5. Reinstalled Windows 7.
6. Switched from a dynamic to a static IP Address
7. Changed from Home Network to Public Network and vice versa.
8. Changed the Network Address, and then also changed it to Not Present.
9. IPConfig /release and /renew - got a Media disconnected error, but the router is properly connected. If I connect it to another computer with the same cable and router port, it is fine.
10. The router and modem are working fine, only this one computer cannot connect to the Internet
11. Disabled, enabled and created new Local Area Connection.
12. Updated the firmware on the Linksys router.
13. Booted in Safe mode with network, no luck either.
14. Turned off all non-MS services. Turned them back on when that wasn't the problem.
15. Reset WINSOCK entries to installation defaults: netsh winsock reset catalog, Reset TCP/IP stack to installation defaults. netsh int ip reset reset.log, Rebooted the machine. Still no luck.
16. Did a new virus scan, malware scan, defragged the disk, disk clean, and registry repair.
17. No McAfee, Norton or other conflicting virus programs are installed.
18. No security issues seem to be affecting this either.


The computer was working fine and connecting to the internet until suddenly it wasn't. I installed a Windows update more than a week ago, and things were fine until yesterday. I had created a restore point prior to installing the Windows update, and would have tried to restore to that point, except Windows 7 very kindly erased that restore point for me. Posting my current opinion of Windows 7 would get me in trouble with the moderator, so Ill restrain myself. :-)

Any ideas of what else I can try to get this working? TIA.
February 3, 2011 12:56:28 AM

On a working computer, download and burn to disk a copy of ubuntu or some other linux Live CD. Boot off the CD and see if the computer is able to connect. It sounds like you may have a defective PCI/PCIe slot on your motherboard that is housing the NIC. By re-installing windows, you eliminated the fact that an update or any other software for that matter could have caused the problem. At this point the problem is hardware related. Let me know how the live cd works out.
February 3, 2011 9:20:09 AM

Installed Ubuntu as suggested and sure enough, it wouldn't connect to the network either. So it's a hardware problem that looks like it will cost me a few $$ to solve. Thanks for the help! It was certainly driving me crazy.
February 3, 2011 2:15:11 PM

Sounds like the motherboard. I would start there. If you have multiple PCI/PCIe slots, try moving the card to a different slot just to be sure before you start swapping the board.
!