Sign in with
Sign up | Sign in
Your question
Closed

Radeon 6770 for Skyrim not showing up.

Last response: in Graphics & Displays
Share
November 11, 2011 9:30:30 PM

Hello,
I have a Radeon 6770 for my graphics card. I should be able to run Skyrim pretty damn well, but in the video menu, it doesn't show up as available, only the Mobile(R) Intel HD Graphics, which makes the FPS in the game equate to a pile of fecal matter.

How do I get the 6770 to show up in the graphics menu? Thanks.
November 11, 2011 9:43:04 PM

So are you using the HD6770 or are you still plugged into the motherboard?
Score
0
November 11, 2011 9:58:20 PM

Sounds like he's using a Laptop 6770 GPU w/integrated Intel GPU. What model of laptop do you have. There is usually a manual way to set the GPU to the Dedicated GPU.
Score
0
Related resources
November 11, 2011 10:17:59 PM

lunyone said:
Sounds like he's using a Laptop 6770 GPU w/integrated Intel GPU. What model of laptop do you have. There is usually a manual way to set the GPU to the Dedicated GPU.


I'm using a dv6.
Score
0

Best solution

November 11, 2011 10:26:04 PM

BillThePenguin said:
I'm using a dv6.

Please give a little more detail than just "dv6". There are about 12-15 "dv6" models out there, so without more specifics, it's hard to tell you what to do.

Here's is tidbit I found here:

"On my wife's system with ATI switchable graphics, the system defaults to always running the discrete card while plugged in and switching to IGP when unplugged. That being said, you can right-click on the desktop and open "Configure ATI PowerXpress" to manually select which adapter is active and you can turn off the auto-switch feature there as well."
link to where I found this.
Share
November 11, 2011 10:28:33 PM

Best answer selected by BillThePenguin.
Score
0
November 11, 2011 10:29:29 PM

lunyone said:
Please give a little more detail than just "dv6". There are about 12-15 "dv6" models out there, so without more specifics, it's hard to tell you what to do.

Here's is tidbit I found here:

"On my wife's system with ATI switchable graphics, the system defaults to always running the discrete card while plugged in and switching to IGP when unplugged. That being said, you can right-click on the desktop and open "Configure ATI PowerXpress" to manually select which adapter is active and you can turn off the auto-switch feature there as well."
link to where I found this.


Thanks mate, even though you didn't help me, right-clicking the desktop led me to an options menu where I can put the 6770 to High-Performance on Skyrim.

Thanks a hell of a lot.
Score
0
November 11, 2011 10:38:42 PM

Glad I could help. I don't own a laptop with switchable graphics, so sorry I didn't have a direct answer for you, but I'm glad it worked out for you :)  Enjoy the game, it's looking pretty good :) 
Score
0
!