Sign in with
Sign up | Sign in
Your question

X-fi Titanium randomlly stops working.

Last response: in Components
Share
April 22, 2012 3:24:40 AM

I recently got a refurbished X-fi Titanium and I'm having trouble with it already. When I first installed the card to the 1x pcie on my p8p67 deluxe, I was unable to switch my speaker configuration or switch mode. Right after I switch my from 5.1 to headphone, the audio stops working. I manage to fix this issue by using a full pcie slot, but there is still some issues. When I switch effects or change mode or channel, the audio would stops randomly from time to time. The sound always worsk again after a restart. Has anyone ever had this issue before.
April 24, 2012 2:32:06 PM

killer8297 said:
I recently got a refurbished X-fi Titanium and I'm having trouble with it already. When I first installed the card to the 1x pcie on my p8p67 deluxe, I was unable to switch my speaker configuration or switch mode. Right after I switch my from 5.1 to headphone, the audio stops working. I manage to fix this issue by using a full pcie slot, but there is still some issues. When I switch effects or change mode or channel, the audio would stops randomly from time to time. The sound always worsk again after a restart. Has anyone ever had this issue before.

This is sounds like a driver issue really.

The things you could do to troubleshoot are to completely disable any onboard sound (in the bios if you can, but in the OS if thats your only option).

Then, maybe use something like Revo Uninstaller to completely remove the drivers. Once removed install the latest from Creative's website.
m
0
l
!