Sign in with
Sign up | Sign in
Your question

ECS A885GM-A2 - PC Powers up but nothing on display - not power supply

Last response: in Motherboards
Share
March 4, 2013 7:24:21 PM

Hello,

I'm having a heck of a time dianosing a problem I've been having with my PC..

I've got a custom built pc with an ECS A885GM-A2 mother board with an amd 1035t processor, (4x4gb)16gb of corsair 1600mhz ram. I've got a 90gb OCZ agility 3 SSD, a 500gb, 1.5tb and 2tb SATA HDD's, a usb 3.0 pci card, a usb 2.0/sata/ide/esata pci card. As for video cards I've got two, an nvida geforce 210 and a raddeon 6670hd and a BRAND new ultra 700 watt power supply..

So heres my problem. My PC will always turn on - fans and hdds spin, cd roms and leds are on - but it will not always put things on the display..

I have read a numbe rof posts and had thought maybe I had a dieing power supply so I bought a brand new one and unfortuantly I'm still having the same problem. When my pc comes on it works great! but so many other times it just wont come on.

I've tried testing all the componets individualy, and I seem to be able to get them ALL to come on at some point or another, but eventually, it wont display anything again..

Anyway i suspect its my mobo/pci express slot is going out?Thoughts? anyway to test that? I don't want to buy a new motnehr board without knowing for sure... but I can't seem to think what else it could be.
a b V Motherboard
March 4, 2013 10:07:04 PM

First of all, you should try to test the system with minimum hardware include the CPU, one memory, one VGA card. It everything is OK, plug in one of the hard drives which has OS. After that, plug in the hardware one by one to verify this issue.

Sometimes, grounding may cause the issue. You can try to test the motherboard outside the case.
m
0
l
March 4, 2013 10:19:24 PM

Thanks for the reply... since posting I've stubbled accros another thread on this form - a checklist of things to look for/at if your system doesn't boot up... I've done the bare min testing and have even gone so far as to do a "bread boarding" test to rule out any shorts with the case...

I guess I should also state that this is an "intermitint" probelm, although the system will more often NOT post/boot vs actually booting... anyway ran across another forum that this could be indicitive of bad caps..or caps that are going bad?

Finally while doing some bare min componet tests I could get it to boot with vasarious configurations of componets.. so I think it's the mother board..

I'm wondering if it could be a bad solder connection somewhere? is tehre any tricks like thowing the Mobo in the over to do a solder reflow type of thing that I might try in a last ditch effort????

Thanks... oh, and BTW - any sugestoins on a good replacement mobo or even thoughts on if I should replace the CPU too?

Quick edit/more info - also, prior to faililng to post, often times it would hang at the first screen/bios info screen... i'd power off, try again and it would start. now it's almost never starting
m
0
l
Related resources
March 4, 2013 10:30:39 PM

Actually - One more edit - I see your an ECS rep... how long is the RMA policy? I've actually not had this MOBO for all that long.. maybe just over a year.. from what I was readingon the website I might still be able to RMA it?
m
0
l
a b V Motherboard
March 4, 2013 10:33:22 PM

If there is any bad component on the motherboard, you won't get the post all the time. On the other hand, it's hard to give you the conclusion based on your description.

If you still believe that the motherboard caused this issue, you can try to flash the BIOS on the motherboard. Sometimes, corrupt BIOS may cause this issue.

You can check the following link for the latest socket FM2 and AM3+ motherboards:

http://www.ecs.com.tw/ECSWebSite/Product/Product_Model....

http://www.ecs.com.tw/ECSWebSite/Product/Product_Model....

m
0
l
March 4, 2013 10:52:14 PM

I'll try to reinstall the bios.. however is that the one I want? My manual says my chipset is AMD 880G.... I see that one listed under the AM3 catagory..

Also, why would this not be the mother board? I've tried it using the onboard video card and ONLY one stick of ram swithc out all 4... even if it was a bad memory module, the chances of all being bad are nill.. PLUS, when it does post with all 4 in the slots, it reads all 16gbs..

Anyway I found out the date of purchase.. I've not had this mobo even a year.. date of purchase is 2/23/2012 from Newegg.

Thanks for the help (and patience with my poor spelling) thus far

- Sorry one more claririfafction... I DO NOT get it to post all the time.. it almost NEVER posts. Once in about 20 tries it will post and show something on the screen
m
0
l
March 5, 2013 1:27:49 AM

How do I reinstall the BIOS if I can't get anything to disply on the screen???
m
0
l
a b V Motherboard
March 5, 2013 3:58:33 PM

Unfortunately, you can't flash the BIOS if the system can't get the post. Based on the purchase date, your motherboard is still under warranty. You can go to the following link to apply 99 hours VIP replacement service:

http://www.ecsusa.com/ecswebsite/member/loginpage.aspx
m
0
l
March 5, 2013 5:16:39 PM

Thanks - I'll get the process started.. I really appreacite all the follow up and respones to this issue!
m
0
l
March 17, 2013 9:32:17 PM

Hi there - I just thought I would follow up... I've pulled the motherboard out and it's on it way. Thanks for the RMA info!

I also thought I share some additional findings... since I've last posted, I’ve purchased a new motherboard. I've installed it and have used all of the exact same components that I had used with the ECS motherboard that is on its way for RMA service. Since installation of the new motherboard, I have not experienced the problem described above. I think it’s safe to say that the ECS motherboard was failing/ had failed.
Again, I appreciate the help and look forward to getting my replacement motherboard!
m
0
l
March 30, 2013 12:41:00 PM

Final follow up... they were unable to repair/replace my mother board with an exact copy so they provided me with an A890GXM-A2 as replacement. This is a good upgrade complete with HDMI and USB 3.0! I've already put my system back together with a replacement MSI board.. but am in the process of building another PC with this board. Overall, although a PITA that my old MOBO fried, very happy with ECS customer service and thier 99hr RMA Service (or whatever they call it). Thanks!
m
0
l
!