Sign in with
Sign up | Sign in
Your question

AMD Phenom II X4 910 throttles

Last response: in CPUs
Share
April 22, 2012 10:45:02 PM

I have an HP desktop with an AMD Phenom II X4 910 CPU and for some reason, the CPU desktop gadget keeps showing the CPU throttling down to 1898ish, 1378ish, and 780ish MHz when booting up, performing tasks, idling, etc. I've cleaned the dust out of my case/heat sinks and my CPU temp hasn't gone above 60C.

Also, it consistently uses 9-15% usage when just having Firefox open (probably a separate issue); I only notice this because I have a notebook with an i7-2670QM that shows only 1-3% overall CPU usage with iTunes, Windows Live Mail, and Firefox open (both computers would have the same tabs open in Firefox for the sake of consistency). I know my notebook's CPU is a bit nicer than my desktop, so I figure the usage is due to that, but I don't remember my desktop's "idle" usage being this high (only processes showing usage are firefox.exe - 9 to 15%, sidebar.exe - 2%, and dwm.exe - 1%).

Is this something the BIOS is doing and should/could I fix it by controlling it with overclocking software? This is just an HP desktop I bought from Best Buy years ago, but I want it in good working order.
April 22, 2012 10:47:53 PM

Here are some SS of what I'm seeing:

SS of My Computer Properties:


"Normal" CPU, had to catch the SS of it while it was showing it's max clock:


"Throttled" CPU clock (varies from 780/1378/1898 MHz on the meter)
m
0
l
a b à CPUs
April 22, 2012 11:09:52 PM

This what it is supposed to do and yes it is a combination of multiple BIOS settings. If you were to open a very CPU intensive program (like benchmarking software) You would see the frequency jump right up to the full 2600Mhz. The purpose of these settings are to reduce unnecessary voltage consumption/heat generation by the CPU in low usage situations.
m
0
l
Related resources
April 22, 2012 11:57:22 PM

Blah, it just feels sluggish now. I was hoping there was a fix and it'd be a bit speedier. I may end up re-pasting the CPU and then maybe look into OCing it. Thanks for the response!
m
0
l
a b à CPUs
April 23, 2012 12:08:18 AM

I presume you cannot turn off such items as 'Cool and Quiet' in your BIOS?
m
0
l
a c 283 à CPUs
April 23, 2012 12:56:55 AM

+1 Teh_Gerbil If you really want to run full speed all the time just do that and set the Windows Power Plan to Performance @100%.
m
0
l
a b à CPUs
April 23, 2012 1:52:41 AM

@DJDeCiBeL That is what he is looking for! He probably is on 'Balance Mode' in Windows, so that throttles the cpu speed at the computer's whelm. Your computer then can have a hard time judging when it should throttle at it's max, thus the cpu speed bouncing around and causing your sluggishness. Control Panel - Power Options & then switch it to High Performance mode. That way your cpu's max clock speed is always set... to the max.
m
0
l
!