Closed Solved

Videocard just hit 100 degrees C Please help!

Hi,

I have an Ati Radeon HD 57770 and after playing Skyrim on medium settings for 2 hours my videocard just hit 100 degrees C and shut down the game.

I have never seen it hit this temperature before. It is not overclocked, but I do have it set to always run the fan at 100%.

Any ideas on what to do? I have the latest drivers, and updated today.

My other specs are:

Windows 7 64bit

Core 2 Quad Q9300.

Not water cooled or SLI.

Please help and thank you!
6 answers Last reply Best Answer
More about videocard degrees help
  1. the game doesnt have a in game v-sync option cause its a port. Enable it in the CCC
  2. Best answer
    What case do you have and what is the fan layout (intake front/exhaust rear)?
    What size are the fans that you do have in the case also?
    Is your case wedge in somewhere, where it can't breath (intake and exhaust air)??
    Is the computer located next to a heating vent or heating source??
  3. gnomio said:
    the game doesnt have a in game v-sync option cause its a port. Enable it in the CCC


    The game doesn't have an in game vsync option because its forced to 60fps by the game by default. You'd have to use the console to override it like toms did in their review
  4. unksol said:
    The game doesn't have an in game vsync option because its forced to 60fps by the game by default. You'd have to use the console to override it like toms did in their review

    The driver can override it as well
  5. gnomio said:
    the game doesnt have a in game v-sync option cause its a port. Enable it in the CCC


    Thank you so much! I was having the same issues, with my video card hitting 100c. I tried cleaning it and everything else in my case, as well as other things. After enabling Vsync w/ Triple Buffering, it is not going over 60-65c.
  6. Best answer selected by frostedone.
Ask a new question

Read More

Radeon Graphics