Sign in with
Sign up | Sign in
Your question

Error: 0xc00000e9 when installing windows after fresh build

Last response: in Systems
Share
January 11, 2012 12:56:56 PM

Hello,

I just completed my first build, and am getting an error when attempting to install Windows (Error: 0xc00000e9, "...problem communicating with a device connected to your computer...can be caused by an external USB device...or by faulty hardware such as a hard drive or CD-ROM drive that is failing"). The error occurs while "Windows is loading files" is on the screen for about 10 seconds.

Some info: Motherboard is an ASRockZ63. I have two hard drives in the box (one Crucial 64gb SSD, and a Seagate 1TB drive), and have got the same error when switching between them individually. When I look at the BIOS, the CPU, RAM, HDD and CD Writer are all recognized correctly. I've set the mode to "AHCI" on a suggestion from a similar thread I found on Google.

Boot order is AHCI DVD Drive -> AHCI HDD -> UEFI DVD Drive. The only USB devices I have plugged in are my keyboard and mouse (same error with just the keyboard plugged in).

Does anyone have ideas as to what's going on, and how i can fix it? If any more information is needed, let me know and I'll provide it.
Thanks,
January 11, 2012 1:17:29 PM

Attach your SSD to the motherboard SATA0 connector and don't connect your HDD until after your Windows install.

Insure that your connections for SDD and DVD cables are tight. Don't connect the DVD to a SATA III connector (use a SATA II).

I would probably also run MEMTESTv4.2 on your memory just to be happy that the RAM is fine, and would also test your DVD connection indirectly.
January 11, 2012 1:17:44 PM

I assume you are installing Windows to the SSD. If so, unplug the Seagate until after install is complete and everything is up and running. Also make sure RAID is disabled in BIOS.
Related resources
January 11, 2012 1:23:25 PM

This is usually from either a bad CD or a bad Hard Drive or one of those two things not being plugged all the way in.

Try taking the cords out of the back of the devices and making sure there are no bent pins or anything then put the cords back in firmly until they can't go in any farther. That might fix it.

Disconnect the Seagate drive completely and just leave it disconnected as you try to address this issue.

Also, change the UEFI DVD drive to be the first thing, then the AHCI one, then the HD.

Check the underside of the CD for scratches or anything that would make it look like it wouldn't work. Rub it with a soft cloth if it appears to have smudges or streaks or anything like that.

Check in the motherboard manual to see if there is a specific slot you are supposed to put the SSD in. Sometimes motherboard makers don't just want you to put it into any random SATA slot.

You can try either IDE or RAID for the SATA drive as well to see if it works, but AHCI should be fine.

Try those things and let me know if there is any improvement.
January 11, 2012 3:18:54 PM

Update: This morning I replaced the DVD drive with a fresh one, and also swapped out the SATA cables for both the SSD and DVD drive. I'm fairly sure the PSU connections to both drives are solid, I can't get them in farther. I'll do a check for bent pins later this afternoon. I have the Seagate unconnected while diagnosing.

Next up, I'm going to try writing a new disc and see if that's the problem. I'll also play around with the drive settings in BIOS a little more. I'll post another update after that.

Thanks for the help so far guys!
January 11, 2012 3:32:53 PM

Setting the boot order to UEFI DVD -> AHCI DVD -> AHCI SSD gives a different error at the same spot. The error said something like "Windows cannot boot because the required boot device is not accessible." I restarted, but haven't been able to reproduce this error afterwards (now throwing the original error code).
January 11, 2012 4:01:15 PM

Switch places in the BIOS for the DVDs and change the SATA cords to different motherboard ports.
!