Sign in with
Sign up | Sign in
Your question

Loading Operating System... Delay

Last response: in Systems
Share
January 12, 2012 2:07:43 AM

I have a Gigabyte Z68XP-UD3P board (i5-2500K) with an Award BIOS. After the POST, I get the words "Loading Operating System..." alone at the top of the black screen. So far, so good.
Then there's about a 20 second wait as periods are printed across the screen. Nothing happens during that time, no drive light activity, nothing. Finally, the "Starting Windows" logo appears, the drive light flickers, and the O.S. loads up in record time thanks to the SSD. What can I do to get rid of the 20+ second delay? I have fast boot enabled in BIOS.
Btw, I have a similar Gigabyte board (GA-990FXA-UD3) also w/Award BIOS in my AMD machine. I get the same "Loading Operating System..." message, But there's no delay with that machine. It goes quickly into loading Windows. Any pointers would really be appreciated.
January 12, 2012 3:34:57 AM

Check what is the Delay For HDD in the BIOS set to, it should be 0 seconds.
Another thing I believe that may be taking it's time is Querying stuff that is not connected to the rig, but is on in the BIOS.
Suggestion, have only those things enabled in the BIOS which you use regularly, I mean like have only those ports configured, coms, usb, etc etc, if you're not using the IEEE 1394, disable it.
Etc etc.
m
0
l
Related resources
January 12, 2012 1:46:06 PM

alyoshka said:
Check what is the Delay For HDD in the BIOS set to, it should be 0 seconds.
Another thing I believe that may be taking it's time is Querying stuff that is not connected to the rig, but is on in the BIOS.
Suggestion, have only those things enabled in the BIOS which you use regularly, I mean like have only those ports configured, coms, usb, etc etc, if you're not using the IEEE 1394, disable it.
Etc etc.

Thanks for the reply. Yes, I have delay for loading the OS set at 0 seconds (that was the default). I thought I had all the non-essentials disabled, but I will check again when I get back to the machine. I'm wondering if the HDD delay is frozen at 20+ seconds due to a stuck bit in the BIOS chip. It's like changing the setting makes no difference. I wonder if doing the "clear CMOS" routine would fix it? Or updating the BIOS to the latest?

One other thing... I always breadboard a new motherboard with just processor/HSF, memory, video, connected (default BIOS settings) to be sure the board isn't DOA. As it was going thru its POST and got to the "Loading OS" point, even then it ran the 20+ seconds of periods parading across the screen before it gave the obvious msg that there was no boot disk available.
m
0
l
January 12, 2012 1:49:07 PM

vx53c said:
Do you have any cd in your cd-rom? Remove and retry. Make sure your first boot drive is your ssd.
Also double check your drive is in ACHI mode. If for some reason you installed windows in ide/sata mode then just: http://www.ithinkdiff.com/how-to-enable-ahci-in-windows...

No disk in the optical drive, Win7x64 was installed to the SSD (1st boot) with all SATA3 and 2 ports set to ACHI. I may disable the Marvel SATA3 to see if that is causing the delay when I get back to the machine, though.

Btw, I followed this turorial for installing Win7 in a new build on a SSD:
http://www.overclock.net/t/1156654/seans-windows-7-inst...
m
0
l
January 12, 2012 2:50:27 PM

If it's been doing this from the very beginning, as you have stated, then I suggest a BIOS reflash or Update would really be a very good idea.
m
0
l
January 12, 2012 4:52:50 PM

I think I struck on an answer for my problem. It appears the optical drive was causing the boot delay. Let me explain for others who may have a similar problem...

I had set the Intel Sata controller to ACHI mode for use with my SSD and HDD. I had those drives connected to the SATA3 ports and the optical drive connected to the 1st SATA2 port. (I had the Marvel controller SATA3 ports disabled). I had set my optical drive as the first boot device as I always do, in case I want to use a bootable DVD/CD.

Apparently, the optical drive was causing the delay because when I set the SDD as the 1st boot device, the boot delay problem was gone. So, to make things the way I like them, I connected the optical drive to the Marvel ports, enabled them, and reset the optical drive back to being the 1st boot device. Problem solved. I never was a fan of the Marvel SATA ports, but this time they came to my rescue.

One added point; my AMD rig with a similar Gigabyte board doesn't suffer from this problem. It has the same model optical drive connected to the AMD SATA port (AHCI) and set as 1st boot device. No problems. Must be the difference in the implementation of the SATA controller code between Intel and AMD.
m
0
l
!