Sign in with
Sign up | Sign in
Your question
Closed

Boot stuck with SSD in ACHI mode

Last response: in Motherboards
Share
March 8, 2013 7:11:16 AM

Hi,

I have a Gigabyte H55M-D2H (BIOS F4, which is the latest).
I have one SSD which is a Crucial M4 (64 GB, latest firmware version), and one DVD Multi drive.
The SSD is connected to SATA port 0 (out of a total of 6 SATA connections, which are numbered from 0 to 5) and the DVD drive to Port 4 or 5.

Anyway, I have Windows 7 installed, and it was installed with the BIOS at IDE mode.
Now I switched to ACHI so I can install Mac OS X (hackintosh), but the boot is stuck at listing the ACHI drives, so I can't access the BIOS or the Quick Boot Menu.

The only way to access them again is by unplugging the SSD and resetting the BIOS to IDE mode.
Problem is, I'd rather use ACHI mode, not only for OS X but for Windows 7 as well.

I have this Win 7 install for about 4 days, before that I had it installed with this very SSD while the BIOS was set to ACHI mode, no idea why it stopped working at ACHI mode.

So how can I make my BIOS like the SSD while it's set to ACHI mode?

Best solution

March 8, 2013 10:54:37 AM

yonyz said:
Hi,

I have a Gigabyte H55M-D2H (BIOS F4, which is the latest).
I have one SSD which is a Crucial M4 (64 GB, latest firmware version), and one DVD Multi drive.
The SSD is connected to SATA port 0 (out of a total of 6 SATA connections, which are numbered from 0 to 5) and the DVD drive to Port 4 or 5.

Anyway, I have Windows 7 installed, and it was installed with the BIOS at IDE mode.
Now I switched to ACHI so I can install Mac OS X (hackintosh), but the boot is stuck at listing the ACHI drives, so I can't access the BIOS or the Quick Boot Menu.

The only way to access them again is by unplugging the SSD and resetting the BIOS to IDE mode.
Problem is, I'd rather use ACHI mode, not only for OS X but for Windows 7 as well.

I have this Win 7 install for about 4 days, before that I had it installed with this very SSD while the BIOS was set to ACHI mode, no idea why it stopped working at ACHI mode.

So how can I make my BIOS like the SSD while it's set to ACHI mode?


I have a ssd also what you will need to do is reset cmos then in bios select achi then reinstall windows 7. Now windows 7 supports and has the drivers for achi so no need to F6 and install 3rd party drivers unless your sata 6 ports are other than intel meaning if the ports are marvell or anyother brand I suggest loading its driver during install (F6). does this help?
Share
March 8, 2013 11:05:44 AM

What helped is cleaning (wiping) all windows partitions using diskpart through the Repair option of the win 7 install DVD.
Apparently AHCI mode doesn't like it when there's this 100mb partition that windows creates at the end of the drive. I reinstalled at AHCI more and all is good.
Score
0
Related resources
March 8, 2013 11:34:35 AM

Great good to hear
Score
0
March 8, 2013 11:49:04 AM

Best answer selected by yonyz.
Score
0
!