Sign in with
Sign up | Sign in
Your question

New ASRock Z77 Extreme4 Power Problem

Last response: in Motherboards
Share
March 9, 2013 3:25:51 PM

I recently purchased an ASRock Z77 Extreme4 motherboard with an i5 processor and G.Skill memory, but when I had everything plugged in, there was no power to the motherboard. I plugged my PSU into my old system and it booted up perfectly fine. I think the motherboard might be DOA, but I just wanted to check before I sent it back in.

System Specs:
PSU: Corsair TX 650W
Motherboard: ASRock Z77 Extreme4
CPU: Intel i5-3570
Memory: G.Skill Ripjaws 8GB
GPU: Nvidia 9800 GTX+
March 9, 2013 3:29:27 PM

I always hate to ask this but:

1. Was everything plugged in properly?
2. Did you make sure all of the front panel connectors were in the right places?
3. Is your setup about to POST with just the CPU, mobo, RAM, and PSU?
m
0
l
March 9, 2013 3:34:15 PM

I plugged in the 24 pin and 8 pin connectors, so unless there's another connection i don't know about everything is seated and plugged in correctly. I've tried powering it on outside the case, but its still the same thing. When i turn the PSU on, no lights on the motherboard come on.
m
0
l
Related resources
March 9, 2013 3:38:56 PM

Hmmm, when you took the motherboard out of the electrostatic baggie, did you make sure you were grounded? It sounds to me like maybe the motherboard is fried.
m
0
l
March 9, 2013 3:44:36 PM

I had an anti-static wristband on, so I was grounded. Guess I'll be sending the motherboard back. Thanks for the help!
m
0
l
!