Sign in with
Sign up | Sign in
Your question

Getting Crossfire to work

Tags:
  • Radeon
  • Crossfire
  • Compatibility
  • Graphics
  • Product
Last response: in Graphics & Displays
Share
November 15, 2011 9:20:18 PM

I got my two 6870's in with the bridge for crossfire, and I know i have a compatible mobo, but it seems like when i played skyrim on ultra with one card, i got roughly 20-40 fps and now its pretty much the same with two in. I downloaded GPUz to see if it was enabled and it said it was. However when I go into the CCC, then to crossfire, i get an enable or disable option, the enable is highlighted but the apply is greyed out. so i disabled it, to reenable it. Once I did that, it stayed on that same screen. How do i get past this screen to see more information about my crossfire? it just stays at the enable/disable screen and i cannot continue.

More about : crossfire work

December 4, 2011 3:49:30 PM

Having the exact same problem with my 5870's.
m
0
l
December 4, 2011 4:31:12 PM

What's your board and psu? And do you have and any other add-in cards installed? ie: sound card, storage controller, usb, etc. ?
m
0
l
Related resources
December 4, 2011 4:38:54 PM

If your motherboard has an x16 and an x4 PCI Express slots this wouldn't be helping, you can lose up to 20% of your performance cross firing in 16/4. However if you have a power supply under 650 watts or if it's not a good quality one there might not be enough power for the system. You'd probably need at least 48 amps on the 12v rails for a 6870 crossfire system.

PS, I had a 16/4 motherboard and a terrible 650w PSU and I had terrible crossfire performance. I still have the same 16/4 motherboard but I have a new power supply and in most games I get a very nice boost in fps.
m
0
l
December 4, 2011 4:45:16 PM

Are you running the11.11b drivers ?

Mactronix :) 
m
0
l
March 17, 2012 3:15:21 PM

I am having the exact same problem. Yesterday we uninstalled and swept all AMD out with Driver Sweeper, reinstalled, still problem. My builder is telling me it can't be a PCI issue; the MSI manual actually has two whole pages on how to correctly install 2 crossfire cards and the setup is exactly right. Powersupply is way over spec.

Our next step is "removing the drivers, removing the cards and then swapping slots (only installing one), installing the driver, rebooting twice, THEN putting the second card in, letting it detect/install the driver, and then setting up Crossfire MAY get it to work again."

MSI X79A-GD45 | SilverStone 1200w Strider Gold | Intel i7-3820 @ 3.6 (stock) |16 gB (researching brand) | 2x Sapphire HD 6850 | 3x 24" Dell Ultrasharps
m
0
l
March 17, 2012 4:23:44 PM

update: I removed drivers, removed cards, installed one, installed 12.1 drivers, rebooted 2x, installed 2nd card.

On reboot AMD popped a message indicating I was in Crossfire. CCC briefly went into a mode where I could NOT disable it - had a grayed out CrossfireX tab, showing 2 GPUs.

I see a "Linked Card" in CCC which to my mind means that CrossFire is working. But I don't see a CCC menu consistent with documentation - I can't configure the GPUs.

I tried Skyrim and it was passable, but deteriorated to about 0.5 FPS after about 10 minutes of play (yes, a frame every two seconds). Enabled AMD Overdrive and it returned to the cryptic behavior: "Choose to enable AMD CrossFireX..." with a grayed out Apply button.

I can choose to Disable it and then I can Apply. When I do that, the second adapter shows as Disabled.

Probably going to go to the 12.2 drivers next, but they have known issues with Skyrim.

Note: I am attempting to play Skyrim across three monitors, 5760 x 1200. Amazed at how challenging this has been, with all new hardware.

Edited yet again: OK, I ran Furmark. Both GPUs were clearly under load, got the temp quickly up to 75c. So it's a Skyrim issue. But not helped by puzzling AMD user interface, inconsistent w/docs.

MSI X79A-GD45 | SilverStone 1200w Strider Gold | Intel i7-3820 @ 3.6 (stock) |16 gB Patriot 1.5v DDR3 (1333 or 1600, researching) | 2x Sapphire HD 6850 | 3x 24" Dell Ultrasharps
m
0
l
!