Sign in with
Sign up | Sign in
Your question

Catalyst driver won’t install on my PC

Last response: in Graphics & Displays
Share
November 16, 2011 1:18:19 PM

I tried to install the new Catalyst driver 11.11 that came out yesterday for my Low profile HD 5450, when I tried to install the driver I got this message “Driver Install: the INF file was not found”. Why can’t I Installed this Catalyst driver into my PC? Is there something wrong with the INF file?
November 16, 2011 2:53:30 PM

Here we go again.... recent Catalyst suites have become a mess.

I'm not sure but u can try driver cleaner - remove all previous ati stuff - and try again.
or look for omega driver package.
last line is amd support. but beware that support on catalyst suite is a dead end for some cards.
I wanted support for my HD2900 pro due to catalyst suite install fail - and the online support form is a blocked dead end.
the same form wasn't a dead end just 3 minutes ago on a different subject. that means if you want support for a certain card it just gets blocked - dead end.
i was quite shocked by this and eventually gave up - i use old driver and deinstalled catalyst completely.
sorry that is all i can write for the moment.
November 16, 2011 3:07:43 PM

designfriemel said:
Here we go again.... recent Catalyst suites have become a mess.

I'm not sure but u can try driver cleaner - remove all previous ati stuff - and try again.
or look for omega driver package.
last line is amd support. but beware that support on catalyst suite is a dead end for some cards.
I wanted support for my HD2900 pro due to catalyst suite install fail - and the online support form is a blocked dead end.
the same form wasn't a dead end just 3 minutes ago on a different subject. that means if you want support for a certain card it just gets blocked - dead end.
i was quite shocked by this and eventually gave up - i use old driver and deinstalled catalyst completely.
sorry that is all i can write for the moment.


I did that and still didn't work, by the way what is a omega driver package? I need that update to run NFS: TR.
Related resources
November 16, 2011 3:32:44 PM

ITsonic said:
I did that and still didn't work, by the way what is a omega driver package? I need that update to run NFS: TR.


a modded driver package which worked better than the ati/amd ones:

http://www.omegadrivers.net/index.php?option=com_content&view=article&id=53&Itemid=53

but they haven't released much recently so no idea how up to date they are now.

have you tried to manually install the driver inf via hardware manager?
I'm REALLY not the ideal person for this stuff anyway...
best of luck!
November 16, 2011 4:21:40 PM

I have had no issues with the latest or any other Catalyst drivers.

Likely you installed the wrong one for your OS or you have a corrupted Windows install.

I would NOT recommend using a modded driver.
November 16, 2011 4:36:30 PM

this sort of thing is exactly why I preach against AMD/ATI GPUs.
November 16, 2011 4:46:10 PM

geekapproved said:
I have had no issues with the latest or any other Catalyst drivers.

Likely you installed the wrong one for your OS or you have a corrupted Windows install.

I would NOT recommend using a modded driver.



Well, no one said this concerns everyone. it's just some cards. and installing the wrong package is not really possible.
it detects the system and if it's incompatible stops the install automatically.
I've seen this problem many times now - in multiple forums - in recent weeks so it is not an individual issue.
The modded drivers by omega are proven - but not up to date, true. i respect your recommendation - but based on what experience?
I had good experience with them and on two occasions they brought better performance than the original by amd/ati.

so omega is an alternative/workaround...
November 16, 2011 5:28:23 PM

geekapproved said:
I have had no issues with the latest or any other Catalyst drivers.

Likely you installed the wrong one for your OS or you have a corrupted Windows install.

I would NOT recommend using a modded driver.


No I didn't use the wrong Driver or have a corrupted Windows install. I got the one for Windows vista 32-bit. Here take a look:

http://sites.amd.com/us/game/downloads/Pages/radeon_vis...
November 19, 2011 5:22:29 PM

geekapproved said:
I have had no issues with the latest or any other Catalyst drivers.

Likely you installed the wrong one for your OS or you have a corrupted Windows install.

I would NOT recommend using a modded driver.


How can the Windows install become corrupt?
March 5, 2012 5:32:57 PM

I did a fresh install of Windows 7 and the same driver I had used before, now didn't work.
I tried updating the driver, going through the selection tree on the AMD website. Still no-go. Read the release notes. They said make sure you have .net framework 3.5 sp1 installed. Could only find 3.5.1 (I think it was). This would not install either. Then I found out that you only need to enable it using "Turn Windows Features On or Off" in Control Panel/Programs/Programs and Features. Did this and still no luck with the driver. Would not install. The installer goes through the motions but you look in the folder that it was supposed to install to and it's empty. Huh. Went back to AMD website
http://support.amd.com/us/gpudownload/Pages/index.aspx

Notice there's an option

Automatically Detect and Install

Clicked on it and it downloads a tiny utility that detects what components and OS you have and then downloads and installs the right package from AMD. It was a 130-some MB download that only took a few minutes 'cause they've got big pipes. Automatically installed and problem solved! Didn't even need to configure my display -- it selected the optimum settings by itself.
!