Sign in with
Sign up | Sign in
Your question

Corsair 1500 Headsets Drivers Wont Install

Last response: in Components
Share
April 27, 2012 10:27:00 PM

I built a new computer a few weeks ago, and installed my corsair 1500's with no issues.

My computer restarted on its own the other night, and I noticed in the morning that my Corsair Icon was missing from the taskbar.

I tried the headsets, and they weren't working. I uninstalled and reinstalled the 1.1 drivers. The driver install instructed me to plug in the 1500. I plugged them in, windows went through its thing, and gave me a failed to install device error.

I went into device manager, and it had the corsair 1500 under sound devices, with the yellow exclamation triangle.

I re-downloaded the driver and tried to reinstall. I have done this multiple times, with the same result.

I'm confused as to why it would uninstall, and then not be able to reinstall. I haven't installed any new software or installed any new hardware.

Motherboard
ASUS P8Z68-V/GEN3

Processor
Intel Core i5-2500K

Memory
G-Skill Ripjaws X Series 8GB (2 x 4GB) 1600

Video Card
ASUS Radeon HD 7850 2GB

Hard Drive
OCZ Vertex 3 120GB

Power Supply
CORSAIR Professional Series HX650

Sound Card
ASUS Xonar DX 7.1

Operating System
Windows 7 x64
April 28, 2012 1:15:27 AM

Make sure you end all processes associated witht he 1500, then unistall again; reboot, and reinstall.

Let us know how that worked.
m
0
l
April 28, 2012 1:31:14 AM

I can't believe after being so frustrated, the fix was so simple.

I went into device manager and instead of uninstalling the driver, I uninstalled the headsets. I never restarted, but about an hour later i went on to the computer and windows started installing them. thankfully, it was successful.
m
0
l
!