Sabertooth 990fx & i get a solid red CPU LED

Hello I bought the
Sabertooth 990fx & i get a solid red CPU LED light on.
It won't POST, power on self test

($174.99) MB ASUS SABERTOOTH 990FX AM3+ R
($169.99) CPU AMD|PH II X6 1100T 3.3G AM3

VGA GIGABYTE|GV-N560UD-1GI GTX560TI
1 x ($104.99) PSU CORSAIR|750W

MEM 4Gx2|PNY MD8192KD3-1333 R
CASE FRACTAL DESIGN|FD-CA-ARC-BL

Monitor Samsung 940BF DVI & Analog

I have to buy a SATA HDD , recommended 500gb?. Old ones are IDE

Possible Fixes:
- Test Mother board outside case
- Replace power supply
(I have a 250 W from old comp)
- Test Mother board battery

What is the problem? Thanks!
3 answers Last reply
More about sabertooth 990fx solid
  1. what? You have 250 watts psu and you're running your entire system on this wow strange thats your big problem.
  2. No. the 750 W is in the new Comp.
    I could try to replace this
    250 W is in the old Comp

    I'm frustrated i finally got these parts & somethings not working.

    I'll try booting with 1 RAM
  3. Try pushing the button on the io ports on the back of the board, the little bios button, it worked for me, I had this problem. If that doesn't work, then update the BIOS. If still no joy, then take out the battery for a few mins. If none of those work, then one of your components could be faulty. :))
Ask a new question

Read More

New Build Sabertooth CPUs LED Monitor Systems