Sign in with
Sign up | Sign in
Your question

Radeon HD 5770 black screen when playing games

Last response: in Graphics & Displays
Share
November 17, 2011 4:28:06 PM

Hi,

I have had the Graphics card for about a year, with no problems. I got a new motherboard, CPU and RAM. Installed it with clean install of Windows. Now everytime i play a game like WoW or Skyrim, if i do anything GPU intensive the screen goes black, the sound continues for a few seconds then freezes and the GPU fan starts making a lot of noise. No BSOD. i have to restart the computer to get it working again.

I can watch movies, go on the web and whatnot without any problems. switched it for an old GPU and there are no issues, so i know the cause of the problem. Just not how to fix it?


Specs:

Motherboard: ASRock Z68 Pro3

CPU: Intel Pentium G840

GPU: ATI Radeon Sapphire VAPOR-X HD 5770

System Memory: 8gb DDR3 1600 MHz

PSU: Corsair 550W

Windows 7 Ultimate 64 Bit

- All drivers are updated -


Any and all help is appreciated.
November 17, 2011 4:59:00 PM

Have you checked the temps? Did you overclock it at all? How long do you play before it crashes?

I had a similar issue with BFBC2... ended up being the motherboards' sound card was not compatible with the game.. so I had to install a sound card and disable the onboard motherboard...(still using that sound card to this day)

Have you checked your error log?
November 17, 2011 4:59:49 PM

Also, mine would play an infinite loop of the audio...
Related resources
November 17, 2011 8:23:13 PM

Is isn't overclocked. I have even tried turning down the clock cycles. It isn't overheating either. CPU and GPU temps are well within limits. I have now tried both with and without onboard soundcard.
November 17, 2011 8:34:51 PM

hmmm can't guess what is wrong ...

My ATI 5770 is 2 years old but still running ok.

hmmmmm.....

No OC, default option, fresh install, even with new board..

That case must check the gpu condition.

try to go back to old main board and see if does black screen come up.
Then card is dead.

if your RMA is still a ok go for it.
my xfx ati 5770 covered "ok" for long time~
November 17, 2011 10:15:18 PM

Have you tried rolling back the drivers. When I was running xfire 5770s, new driver releases were hit or miss. I think at the time, 10.4 was the version that worked the best for my set-up. Do a driver sweep and try a previous version of the drivers, maybe start with the version that worked before your new build and go from there. Might solve the issue.
November 21, 2011 10:47:00 PM

Where can i find old drivers? the oldest i have been able to find is 11.8, and thats not doing anything
November 27, 2011 1:06:40 PM

Tried the card in a friends computer, and it worked flawlessly. Maybe it's not compatible with my motherboard in some way, i don't know?

Havn't found any older drivers that work. Running my old graphics card until i can afford a new one. Gonna try and sell the 5770. :( 
!