Sign in with
Sign up | Sign in
Your question
Closed

64 bit RAID drivers not working

Last response: in Windows 7
Share
January 4, 2012 12:34:50 AM

Before I can install windows I have to upload the RAID drivers for my motherboard. There's 2 folders x86 and x64. I want x64, except only the x86 drivers will load. Even when I click "Load drivers that aren't compatible." the x64 drivers don't show up. I have used the x64 RAID drivers from the disk I was given with the MOBO and I have tried the drivers directly from the ASRock website. Oh, and I've checked both the x64 folders. They aren't empty...

ASRock 990FX Extreme3 AM3+
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Western Digital Caviar Blue WD2500AAKX 250GB 7200 RPM
http://www.newegg.com/Product/Product.aspx?Item=N82E168...

Best solution

a b \ Driver
a b $ Windows 7
January 4, 2012 12:53:17 AM

Being that this is in the Windows 7 section of the forums, you do know that 7 has RAID drivers included right? You do not have to load them like you did with XP.
Share
January 4, 2012 2:32:53 AM

Unfortunately it doesn't have all the RAID drivers. They were required to be manually installed. Any way this is how I fixed it:

Since the installation couldn't pick up the drives with out the RAID drivers I installed the 32 bit drivers first and then my drives showed up. When it comes to the part you you need to select a hard drive to install windows on, I selected my RAID array and clicked the button on the bottom "Load drivers". I was then able to load the 64 bit drivers from the 64 bit folder for some reason...
Score
0
Related resources
January 14, 2012 5:06:56 PM

Best answer selected by eclipszor.
Score
0
a b \ Driver
a c 395 $ Windows 7
January 14, 2012 5:51:54 PM

This topic has been closed by Area51reopened
Score
0
!