Closed Solved

Skyrim and Asus DirectCU II HD 6970 (Low FPS)

When Skyrim determines the best quality it always selects medium quality, when i first got the game i could easily play at ultra with 50-55 FPS but now ultra i would be lucky to get 5 FPS. All that has changed was that i updated the drivers to the 11.11, so i tried downgrading by uninstalling it then install all the 11.8 drivers etc. Still it says medium quality, when setting it to ultra right now i can get around 50FPS inside and outside i get 5 FPS were as i used to get 50 or 55.

Specs:
AMD Phenom II X4 955 Black Edition @ 3.6GHz
8 GB's of GSKill RAM
Gigabyte 880GA-UD3H Mobo
Asus DirectCU II HD 6970 @ Stock settings on 11.8 drivers
5400RPM 500GB HDD

If you guys need any info from me i will provide it, im just trying to find out why my graphics card performance has gone to crap.
10 answers Last reply Best Answer
More about skyrim asus directcu 6970
  1. Hello & Welcome.
    So what iam understanding is that you experience a massive drop in FPS suddenly.
    review this thread and try the fix stated by the OP and report back if it works
    http://www.tomshardware.com/forum/332396-33-6950-issues-skyrim-possible-solution-inside
  2. I updated all the drivers for it to the 11.11 update and using the settings here:http://i.imgur.com/IHdqO.png i get 1 or 0 FPS, i am running my GPU at stock settings.
  3. Download GPU-Z and see your core/memory clocks and also your temps, check that the CPU is running @ the full speed, disable "Cool n Quite" if necessary.
  4. http://b4c0n.com/i/d8bfd.png

    I disabled cool n quiet, still with no avail it wont run at the settings that are displayed in the imgur link. I am getting 2 -3 FPS though, in order to play i have to take AA down to 4x without EQ
  5. Best answer
    Your bus interface is running at x1 instead of x16. The card is not properly functioning. I've found, most the time this occurs, it's due to a poor seating of the card. Try removing it, cleaning the contacts and blowing out the slot and reinstalling it.
  6. Oh well i feel like a dipsh** haha i just saw that on GPU-Z
  7. That's kinda weird, first time to see such a thing, if it still reads PCIE 1.0, try to update to the latest BIOS, ensure that the card is properly installed in the first PCIE x16 slot.
  8. It makes sense now, i had taken my computer apart to do some cleaning and i guess i didnt seat the card right when i put it back together. Its now running perfectly again, all i had to do was take the card out and replace it.
  9. Best answer selected by speedycuban.
  10. It's always nice when the fix is easy.
Ask a new question

Read More

Radeon FPS Skyrim Graphics