Solved

AMD FX 8150 only running 2.8 out of the box

I recently set up 5 of these builds for use as a render farm:

GIGABYTE GA-880GM-USB3
AMD FX 8150
350w PSU
16 GB DDR3 ram


Out of the box on all machines, I am getting only 2.8ghz from each core. They are supposed to be 3.6...

What could be going on? I first suspected the PSU but its not even maxing out the full 350w.
Reply to aromakat
21 answers Last reply Best Answer
More about 8150 running
  1. Is this speed 2.8 under load or at idle? If at idle, them it's OK. If it's under load, then there's a problem with your cpu ratio in the bios.
    Reply to abekl
  2. I tested with a benchmark in Linux and it said it was running 2.8

    In Windows, I haven't run a benchmark but in the system properties it says AMD FX 8150 8 cores @ 2.8

    I will post the bios settings in a bit
    Reply to aromakat
  3. Update your bios.
    Reply to amuffin
  4. I think I did.

    I downloaded the bios update from the gagabyte site. It was an exe which was odd to me but I have never updated a bios before. It seemed to install fine but with no change to the speed after restarting
    Reply to aromakat
  5. That 2.8 ghz is your C1E state. The cpus have 4 different speeds. Idle, 7x multi, C1E, 14x, stock 18x, and turbo 21x.

    C1E is a dual purpose state. Its primarily for saving power when the cpu is on a light load. It also kicks in to protect the motherboard and cpu itseld from overheating and overdrawing power.
    Reply to noob2222
  6. the lasted bios is fe from there web site. the exe that downloaded from there web site does not flash the bios just extracts the bios flash file to a location where you can find it. they easy way to flash these boards is put the flash file on a usb stick and go into the bios update on the mb at boot you hit an f key. it a dos screen so all you have to do is tab over to the flash file and say update. the bios update will ask if you want to safe the old flash say yes.
    Reply to smorizio
  7. tried changing the multiplier settings and updating the bios, but it didn't work. so i had to take the battery out and reset it. I tried what smorizio stated, but it doesn't seem to work either. it said there was no disc.
    Reply to aromakat
  8. @abekl:
    Just ran cinebench to put load on it, and the speed was stuck at 2.82 ghz.

    No change idle vs load


    @noob
    It doesn't seem to dynamically change with load as described. How would I change it to be, for example, always in turbo?


    @smorizio
    I downloaded the bios and extracted it to a USB. When I load up Q-Flash with the USB stick in, it says 'no disk detected'. Also, when I try to run the .exe it says that its not available for 64 bit windows.
    Reply to aromakat
  9. I just saw this on the gigabyte website...

    Could this be the issue??

    http://www.gigabyte.com/support-downloads/cpu-support-popup.aspx?pid=3809
    Reply to aromakat
  10. looks like it yeah. the support list shows a max clock of 2.8GHz.
    Reply to americanbrian
  11. Best answer
    Make sure your checking your speeds with AMD Overdrive. CPU-z only refreshes ~5 sec intervals, may be catching only the 2.8 ghz speeds. AOD monitors the speed at real time.

    the only way to work around the dynamic change in the cpu is to overclock it. On the screen where it has C1E, disable it. On the MIT section, motherboard intelligence tweaker, change core performance boost to disable, and change the core clock ratio from auto to between 20 and 22 to start off with. The reason you disable core performance boost is your going past that point anyway. With it enabled, it will spike the voltage on your cpu, you don't want that.


    For stability testing change the system voltage control to manual, go down to cpu voltage control and set it to about +0.05V to +0.1V. Then its stability testing to make sure it runs ok.

    As for updating your bios, do this before messing with any of the settings. I have flashed many gigabyte boards. I always did it in windows with @bios found here. http://www.gigabyte.com/products/product-page.aspx?pid=3809#utility

    Edit: just saw the post from the cpu support list. Interesting that the 8100 only shows 2.8 ghz. you might still be able to manually force it to 4.0 with what I said.
    Reply to noob2222
  12. Thanks!!

    Using those settings it came up as 4.4ghz but crashed soon after running a cinebench test, so I guess that was just too high.

    I will tinker with the settings from here.

    What is recommended for stability testing?
    Reply to aromakat
  13. most people use prime 95.

    Your speed limit will probably be the motherboard holding the cpu back rather than the cpu hitting its limits. If you got to windows at 4.4, you should be able to get 4.0 easy enough to stabilize. With that motherboard its going to be hard to tell if your pushing too much voltage for the board to handle or not enough for the cpu.
    Reply to noob2222
  14. turn off cool and quiet in your bios as well so that your cpu doesn't throttle under load like prime 95.
    Reply to ohyouknow
  15. You do realize cool n quiet only throttles when the cpu is doing absolutely nothing right? No reason to disable it except to keep the power meter running at full speed when the computer is on and not being used.
    Reply to noob2222
  16. I had issues with it when I did an overclock and ran prime 95 even playing BF3. It was downclocking for me. Turned it off and problem solved. While it might work differently for others, that was my experience.
    Reply to ohyouknow
  17. I have only 2 ideas.
    1. Check if cool and quiet is enabled, if it is disable it
    2. Set your multiplayer until it reaches 3.8 ghz
    Reply to davemaster84
  18. Best answer selected by aromakat.
    Reply to aromakat
  19. Following Noob's tips got me to a steady 3.6. I could probably push it higher but since its use is strictly for rendering 3d at 100% load for days at a time I would rather be sure its extremely stable and wasn't planning on overclocking in the first place but wanted the 3.6 ghz I paid for.

    I guess its technically overclocked to get there - as the board doesn't support the 8150s (yet at least).

    Thanks again everyone!
    Reply to aromakat
  20. https://www.gigabyte.com/Motherboard/GA-880GM-USB3-rev-31#dl
    Hear you can see that it was mentioned to update your bios to the latest version for AM3+ AMD series.
    Update it to latest version of bios

    Bro I was using the same processor and board too. I updated my bios version to FD released on 29/8/2011 which was the 1st update for AM3+ https://www.gigabyte.com/Motherboard/GA-880GM-USB3-rev-31#dl
    and it was amazing I finally got 3.6ghz frq with out boosting the clock frequency. BUT USE A GOOD SMPS OF OVER 500WATS. (WHICH WAS MENTIONED IN MOTHER BOARD MANUAL)
    Reply to abhijithasdeveloper
Ask a new question Answer

Read More

CPUs AMD Gigabyte Render Farm