Sign in with
Sign up | Sign in
Your question
Solved

Need help from the network gurus.

Last response: in Networking
Share
February 10, 2011 2:41:18 AM

I have the comcast modem pictured here.
http://mydeviceinfo.comcast.net/DisplayCMDevice.php?dev...

I have the Linksys WRT54G router seen here.
http://www.minetfiber.com/wrt54g.html

I put a WPA password on the router no problem. I have 3 wireless computers that can see it, insert the password, and get on no problem.

However, I have 1 desktop computer that isn't wireless. It is hardwired to an Ethernet port on the router. I haven't found any way to manually connect it to the router, after a password has been set. It can't see the wireless network, because it doesn't have a wireless adapter. When I go to the network and sharing center, and manually try to connect, it doesn't have the option to find the wireless network.

As you can see, there is only 1 port on the modem, so I can't connect the PC to the modem.

Is there a way to get this wired desktop to access the WPA network, without having to make it wireless?
Thanks
-Aaron

More about : network gurus

February 10, 2011 3:46:42 AM

WPA is a form of encryption, and is in no way a separate network. Depending on your configuration, all of your computers should be on the same network. WPA is just used so that other people cannot access your LAN without your permission, therefore is not necessary for wired connections, for obvious reasons. Also, you'll want to plug your PC into the router, not the modem. The modem's ethernet connection should go to the WAN port on the router, giving you a connection through the ports on the router.
m
0
l
February 10, 2011 12:37:15 PM

Thanks for the responses so far guys.

At the moment, the problem isn't with file sharing. But I'll keep that in mind.

@ Pyroflea
The modem is currently connected to the WAN port of the router. The wired desktop is connected to the 1st LAN port of the router. So they physical connection should be fine.

Everything works fine, and everyone can connect to our network when it's not secured. The problem is, as soon as I enable WPA, only the computers with wireless adapters have the ability to enter the password, and connect. I haven't found where to enter the WPA password for the wired desktop.

If the WPA password isn't required for the wired desktop, why does its connection get disconnected every time I enable WPA?
m
0
l
Related resources

Best solution

February 10, 2011 6:22:39 PM

After you enable WPA the router likely resets and you'll need to restart the stack on the wired PC, easiest way to do that is reboot the computer. If its plugged into the router directly, then it will just work, no matter if the wireless is WPA or not. WPA has absolutely nothing to do with a wired computer.

If after setting the router up and getting the wireless computers to connect successfully, then reboot the wired computer and if it doesn't work, can you tell us the output of:

ipconfig /all

Type that into a command prompt and paste its output here.
Share
February 13, 2011 1:00:29 AM

I want to thank all of you for your help. It seems all that was needed was a restart of the wired desktop.
m
0
l
February 13, 2011 1:00:41 AM

Best answer selected by aford10.
m
0
l
!