Sign in with
Sign up | Sign in
Your question
Solved

SKYRIM 6850 lag

Last response: in Graphics & Displays
Share
November 21, 2011 9:45:15 PM

Here is my setup.
CPU: AMD Phenom II X6 1055t stock
GPU: ATi HD 6850
RAM: 4GB ( Not Certain what kind )
HDD: 500GB (Not sure of RPM, or Brand)
MOBO: Asus 890gx
windows 7 64bit

im getting terrible lag on my setup, skyrim auto sets graphics to high settings and i get mainly 15-30fps (with drops to 6 fps in some sequences) in fraps.
my brother has the same setup but a 5850 and he is running it on ultra everything maxed out and getting smooth 30-40fps.

I have tried updating my catalyst drivers, the ENB thing, large address aware and setting my priority of skyrim in task manager to high.

Nothing has really changed except when i set the priority to high which gives me a minuscule improvement 5fps max.

please help me i wanna play this game!

(smooth)

More about : skyrim 6850 lag

November 21, 2011 11:34:06 PM

1080 x 1920.


m
0
l
Related resources
Can't find your answer ? Ask !
November 21, 2011 11:46:21 PM

Go to the graphics control panel (right click on desktop) and set Anti-Aliasing to "Use Application Settings" - that helped me out immensely. I'm running Skyrim on Ultra settings, actually maxed out, with 2x AA (not FXAA) on an HD 5770 and getting smooth framerates - I honestly don't check for exact numbers because I don't really care as long as it looks smooth to the eye. And this is all at 1080p as well. You should EASILY be able to do the same, and I suspect that you have AMD's driver-based AA override turned on. With it on, at 2x Box AA, I get maybe 2-5 FPS. With it turned off and Skyrim's 2x AA turned on in the settings menu, I'd estimate that it pulls at least 30.

Give it a try. If that doesn't work, I've noticed that a lot of the people complaining about this mention FRAPS - that may be part of the problem too, although that's just a suspicion that I have no way of testing myself.

Thirdly, your 1055 isn't exactly a good processor for this game. Skyrim seems to be VERY processor dependant for the type of program that it is, and a mild overclock of my Phenom II x4 965 from 3.4 to 3.8ghz made the game go from unplayable to perfectly smooth. Seeing that your 1055 is only running at 2.8ghz stock clocks, you're losing a lot of power because of how Skyrim will only run on two cores anyway.
http://www.tomshardware.com/reviews/skyrim-performance-...
If all else fails, try overclocking your 1055 a little and see if it helps.

If none of the above helps, then there's still something wrong. If I can play on Ultra on an HD 5770, you shouldn't have any problems at all on an HD 6850.
m
0
l
November 22, 2011 12:31:51 AM

how do i get to that?? when i right click the only option i have is "AMD vision engine control center"
m
0
l
November 22, 2011 12:45:28 AM

do you have 11.10 installed or 11.11??
m
0
l
November 22, 2011 3:53:44 AM

its your cpu, you need a fast cpu, having 6 cores doesnt help since the game only uses 2 cores. Only an intel SB cpu or highly clocked phenom will run the game smoothly. OC your cpu to at least 3.5ghz.
m
0
l

Best solution

December 6, 2011 1:10:45 AM

Hi kieram, I actually had exactly the same problem. If you're having stuttering where it looks like some frames are skipping or the game is jumpy, try disabling vsync. I found two ways to do this:

1) You can go to My Documents, then to My Games, then to Skyrim, and open Skyrim.ini. In there, look for the part labelled [Display]. At the bottom of that section, before the break before [Audio], place iPresentInterval=0

Make sure to back it up before you change it though, in case you need to revert (I doubt you will).

2) You can open up AMD VISION Engine Control Center, which comes with the newest drivers and Catalyst. This method will prevent problems later. I think it's either in Gaming or Performance, but you'll need to enable Advanced Settings. Turn off Wait for Vertical Sync, or Vsync. This should solve all of your framerate problems.

I had this happen when I played Garry's Mod and Skyrim. After looking around and tweaking, I turned off Vsync and everything worked fine. I hope this works for you!

-XenoPenguin
Share
December 13, 2011 1:49:35 AM

Best answer selected by kieram1995.
m
0
l
May 24, 2012 6:35:26 AM

Hi,I play skyrim on high(4xaa and 8x AF)and get 60fps(has gone down to 25 with extreme screen activity quickly,not noticable)with a phenom 1 9550 which is 2200MHZ,about 30 - 40 on ultra and I have it running about at x8 speed as walks much too slow for me, so I don't understand why u would have to overclock a newer 3.4ghz to 3.8.
I have a HD6850,4gb ram and Asus M3a78 pro with Samsung 1TB F3 and Corsair GT 55mb SSD.WEI 7.1,7.3,7.7,7.7,7.6
Keep an eye on that btw,only supposed to be completely stable @ 3.6 have been reading up as got one on the way.
m
0
l
!