Closed Solved

Gigabyte 1gb Radeon 6950 Problem

Hi I recently switched from Nvidia to AMD because my motherboard does not have sli. I set up all the drivers and installed everything to the latest drivers through the amd site, but when I check my video card, it only says 6900 series and when I go onto canurunit, it says I only have 752.1mb instead of 1gb. Lastly the temp for my 6950 doesn't show up on speed fan. I realize that these aren't the biggest problems, but does anyone know why?
3 answers Last reply Best Answer
More about gigabyte radeon 6950 problem
  1. Best answer
    "I set up all the drivers and installed everything to the latest drivers through the amd site, but when I check my video card, it only says 6900 series"

    It doesn't need to differentiate as the driver is for the entire 6900 series. Don't worry you have the right driver.

    "when I go onto canurunit, it says I only have 752.1mb instead of 1gb"

    Canurunit is unreliable. It drops a file onto your computer and tries to assess your computer's performance. Innacurately. Go to 'yougamers' and it will say different, as it analyses your actual hardware.

    "Lastly the temp for my 6950 doesn't show up on speed fan."

    Download GPU-Z (google it) install and run. Under the sensors tab will be given the temperature. If that doesn't display - there may be a problem with the sensor. But try that first.
  2. Oh alright thanks, all my questions have been solved.
  3. Best answer selected by yomamaismine.
Ask a new question

Read More

Radeon Graphics