Sign in with
Sign up | Sign in
Your question

[SOLVED] Trying to understand why wireless trumps wired

Tags:
  • Wireless
  • Connection
  • Desktops
  • Ethernet Card
  • WiFi
  • Networking
Last response: in Networking
Share
February 10, 2011 12:27:10 PM

My landlord offers free WiFi (thanks!) and I have a desktop with either Ethernet or built in wireless. What I wanted to do was connect the desktop to the wireless internet but also connect the desktop to my home network (so connect it to my own router too with ethernet cable). I got it setup the way I want, but I'm wondering if someone can help me understand why when I connect to wifi now, it takes that default internet connection over mine.

So here's what I did. I turned on the wireless and connected to the wifi network. When I did this, the desktop was still showing that it was using my own internet and NOT the WiFi provided by my landlord. I then when into my adapters settings > right-clicked on the ethernet adapter > went to properties > I then went to the IPv4 settings and I gave the desktop a manual IP address of 192.168.0.2. I then entered in the default subnet mask and default gateway/dns information (I got this info by going to the command prompt and typing in "ipconfig /all")

After that was all said and done, I restarted the computer and when it boots back up it immediately connects to my internet (which is fine). Then when I connect to the wifi network the desktop automatically switches over to that internet connection (like I wanted!) and when I go to whatismyip.com my IP is different so I know I'm not using my own internet anymore :-) WaaLa! I got what I wanted!

But I'm confused.. I don't really understand why giving my ethernet adapter manual settings vs. windows providing it an automatic IP does this :-/ Could someone please help me try and understand?


Thank you!

More about : solved understand wireless trumps wired

a b F Wireless
February 10, 2011 4:19:21 PM

Binding order. Open Network Connection from Control Panel. Click on Advanced menu up top, Advanced again. You will see the Wireless is over the hard wire network. Swap them. That will change the first network that Windows will try to use for connectivity.
m
0
l
February 10, 2011 5:08:37 PM

I'm running Windows 7. I only see "Network and Sharing Center" which then brings me to my active networks, etc. I don't see any advanced buttons.

FIXED. Please see next message below.
m
0
l
February 10, 2011 5:12:14 PM

Nevermind! I got it. I wasn't pressing "ALT" to bring up the menu options so I could get to advanced.

Here this whole time I thought it was because I was giving the ethernet adapter a static IP ;-) wow.. lol it was actually a lot more simpiler than that.

Thanks for helping me understand this easy situation!
m
0
l
!