Sign in with
Sign up | Sign in
Your question

6950 driver crashing at 1920x1080

Last response: in Graphics & Displays
Share
November 23, 2011 12:12:31 AM

Windows 7 64-bit SP1
ASRock P67 Extreme4
i5-2500K
HIS Radeon 6950 2GB --- H695F2G2M
Corsair 8 GB RAM --- CMZ8GX3M2A1600C9
Samsung Spinoint F3 1 TB --- HD103SJ
Corsair 750W PSU --- CMPSU-750TX
Samsung SyncMaster SA350
(no overclocking)

This past April, I built a computer for my brother. He has played Fallout 3, Mass Effect 2, Dragon Age: Origins, and StarCraft II, among others, without problems. Some games, however, habitually crash, and seemingly for the same reason. It first started happening with The Witcher 2 about one month ago, in which the game would usually cause the graphics driver to crash, greeting me with a "Display driver stopped responding and has recovered" message. It does not happen during any other tasks, only in certain games. I first thought that this was a DX 11 issue, but that does not seem to be the case. The very interesting thing is that it only seems to happen in these games when the resolution is set to his native one, 1920x1080. There are some other peculiarities, such as Unigine Heaven crashing at DX 9-11 @ 1080p, but working fine @ 1080p with OpenGL. Here is a list:

Crysis 2
1920 x 1080, DX 11 --- crash
1600 x 900, DX 11 --- OK
1920 x 1080, DX 9 --- OK
1600 x 900, DX 9 --- OK
1920 x 1080, DX 9, texture patch --- OK

Witcher 2
1920 x 1080, ultra, no Ubersampling, no AA --- crash
1920 x 1080, lowest settings --- crash
1600 x 900, ultra, no Ubersampling, no AA --- OK

Metro 2033
1920 x 1080, DX 11 --- crash at menu (menu is in 3D)
1600 x 900, DX 11 --- OK

Metro 2033 Bechmark Utility
1920 x 1080, DX 9, 10, 11 max --- OK

Unigine Heaven
1920 x 1080, DX 9, 10, 11, max --- crash
1920 x 1080, OpenGL - OK
1920 x 1080, DX 9, lowest --- crash
1600 x 900, DX 9, 10, 11, max --- OK

DiRT 2
1920 x 1080, DX 11, max --- OK

Dragon Age: Origins
1920 x 1080, DX 9, max --- OK

Mass Effect 2
1920 x 1080, DX 9, max --- OK

Fallout 3
1920 x 1080, DX 9, max --- OK

Crysis 1 w/ CCC mod
1920 x 1080, DX 10, max --- OK

StarCraft II
1920 x 1080, DX 9, max --- OK

---------------------------------------------------------------------

A few additional things to note as well:

--- When The Witcher 2 is set to a lower resolution, it does not crash, and neither does 1920 x 1080 AFTER playing with a lower resolution first.
--- The Witcher 2 did not immediately start crashing when he first started playing one month ago, only about an hour into the game.
--- Crysis 2 still crashes when switching resolutions, from non-native to 1080p, mid-game with DX 11 enabled.
--- The Crysis 2 crash is not a "Display driver stopped responding and has recovered," but rather, a MSVCR90.dll crash error.
--- YouTube videos sometime stutter; not sure if it's flash or the driver; have not seen this myself, but my brother says that it happens occasionally. The audio stutters when this happens. This also happens when he's watching a video or playing music through the Zune software (Zune software is similar to a media player).
--- The monitor, Samsung SyncMaster SA350, came with only an analog connector (d-sub VGA cable). I had a analog-to-digital connector (the 6950 only has DVI and HDMI plugs). Not sure if this has to do with anything, but the AMD drivers list the monitor's refresh rate as 75, while I've seen some games reference it as 60. Perhaps the change in resolution (1080p to 1600x900) also does something to the refresh rate, causing the game to become stable? Anyway, enabling/disabling vSync doesn't have an effect on this issue.
--- Temps are excellent.

---------------------------------------------------------------------

Some things that I have tried without any luck:

--- Reformatted, reinstalled Windows, loaded the Witcher 2 @ 1080p on a pretty bare system (but with all updates to the core Windows installation)
--- Uninstalled the latest Realtek onboard sound drivers, SATA drivers, Intel drivers, LAN drivers, and pretty much all the drivers that came with the motherboard
--- Used the latest drivers for the motherboard
--- Updated the bios
--- Memtest86+ for several hours -- no problems
--- Bumped up the vccio voltage to the motherboard to second-highest preset option (~1.1, ~0.9 is default)
--- Latest version of DirectX
--- Bumped up the voltage to +20% max AMD overdrive
--- Used an ASUS 6970 bios (first came across the problem while still on the 6970 bios)
--- Flashed back to the original HIS 6950 bios
--- Latest Windows drivers
--- Used ATI drivers 11.11, 11.9, 11.8, 11.7, 11.6, 11.4
--- Changed the power settings to "high performance" from "balanced" in the Control Panel
--- Timeout Detection and Recovery (TDR) registry edit; set it to 8 without a restart

Does anyone have any more ideas for me?
a b U Graphics card
November 23, 2011 12:22:49 PM

If you've tried this and encountered the same problems with multiple driver versions it may be a problem with the card. like you've investigated this pretty thoroughly!

I'd RMA the card and go with the replacement.
m
0
l
November 23, 2011 12:52:38 PM

Thank you for the reply, beltzy.

I'd like to investigate this a bit further before I send back the card. As you can see, one game that does crash, Metro 2033, does not crash while running its graphically-intensive benchmark utility @ 1920x1080. It's a little strange and I'd like to get to the bottom of it.
m
0
l
!