Sign in with
Sign up | Sign in
Your question

HD 6870 Crosfire cards; drivers don't install properly

Last response: in Graphics & Displays
Share
November 23, 2011 6:54:05 PM

Hello Tom's Hardware community,

I'm having issues installing the latest Catalyst drivers for Windows 7 since upgrading some components in my rig. Whenever I run the install pack for the Drivers and reboot Windows to complete the installation, the drivers don't work. This error message pops up: "No AMD Graphics drivers installed, or the AMD driver is not functioning properly. Please install the AMD driver appropriate for your AMD hardware".

I know I have the correct and latest driver version; it's 11.11 for Windows Vista64/Windows7 64.

Here are my rig's upgraded specs:

ASUS Maximus III Gene motherboard P55 chipset
Intel i5 760 Quad core CPU running at stock speed (2.8ghz)
*Newly installed* Coolermaster Hyper 212 EVO aftermarket CPU heatsink
4 Gigs Kingston HyperX RAM (2 x 2GB) 1600 Mhz 9-9-9-27
XFX Radeon HD 6870 1Gig DDR 900Mhz
*Newly installed* XFX Radeon HD 6870 1Gig DDR 900Mhz, connected to old card in crossfire mode; old card is still in its original slot from when it was the only card in my rig
*Newly installed* 6 Coolermaster 120 MM red LED fans; 3 intake, 3 exhaust; all are powered up, running properly, lit properly
Corsair 750 Watt PSU (TX something I think?)

Ok, so here's exactly what I've tried to this point.

A couple days ago, I pulled apart my rig so I could the new components listed as "newly installed" from the above list.

In preparation for installing the second 6870 card, I removed the current display drivers, and ran driver sweeper to clear everything before I pulled apart my rig. When I did pull everything apart, I had to fully remove the motherboard to install the heat sink, so I unplugged everything from the board, including the old video card, before I put the board back in place and then installed card number 2.

The original card is installed in its original PCI-E slot (slot 1) and the new card is in slot 2, so the old card is in the same slot it was in as a solo card.

I booted to windows after resetting the BIOS to default settings;Windows didn't boot until I reset the Bios and changed boot disk priority again, but then it was fine; so bios settings have been reset before I installed the drivers.

In Windows, it ran the new hardware detection process and updated drivers for my Hard disks properly, and started updating drivers for my video cards (I think it only listed it as searching the drivers for one card). I tried to cancel that process since I had downloaded the latest drivers in advance beforehand. I'm actually not totally certain if windows finished upgrading the drivers itself, but after the hardware detection was gone, I ran the CCC + drivers install pack, set custom install and set it to install every component.

At one point during this installation, the windows error pop up appeared saying that the display device had stopped working and recovered. Installation finished "with warnings" that it said to check in the view log, but it didn't show anything extra there; it only listed all components as having installed successfully.

I rebooted and got the error message I posted at the beginning of this post; "No AMD drivers detected, etc."
Looking in the device manager, it showed both video cards as being connected and functioning properly, with no conflicts.
I've since tried uninstalling the drivers and reinstalling them a couple of times, using both the CCC + driver pack, and by installing each of those components separately, with no success. I also ran driver sweeper again and installed the drivers from scratch, but that gives me the same error. I should note that when I installed the CCC separately from the drivers, the CCC installation ended saying it completed "with warnings", but the driver installation by itself after that completed "successfully", except I got the same error message from above when I booted Windows anyway.

I haven't tried any hardware swapping, but from other things I've read I understand that may help, so I'll try switching out the cards when I get home from class today.

Does that sound like it might help? Does anyone have any other suggestions? I'm kind of at a loss here; I've never had it be the case where I couldn't even get video drivers installed to windows at all.

Also, sorry for the length of this post; I know it's a lot of reading, but I understand that more information is better than less for troubleshooting technical issues in general. So many thanks in advance to anyone who takes the time to read this and posts a reply; your help is GREATLY appreciated!

November 23, 2011 7:23:07 PM

What version of Windows are you running? If Win764-bit, have you installed SP1?
I would un-installed the drivers. Shutdown, remove the second GPU, reboot, re-install driver to see if it comes up ok. If it does, then shutdown, re-install 2nd GPU and re-start. Run through the steps methodically to pinpoint where the problem begins.
m
0
l
November 23, 2011 8:53:04 PM

Crap, I knew I forgot something; yes, I run windows 7 home premium 64 bit, and it's an oem license.

I'll try that when I get back to see if the drivers will install with only one card connected. You'll hear back from me again this evening after I get back from class and give this a whirl.
m
0
l
Related resources
November 23, 2011 8:55:08 PM

Oh, also yes, I'm on service pack 1 as well.
m
0
l
November 24, 2011 1:47:38 AM

Alright, so I unplugged the second card, and am down to one card plugged into PCI slot_1. This is the older card that's plugged in.

I've re-downloaded and reinstalled the Catalyst control center and drivers pack 11.11, but even on the single card, the CCC won't open at all. Under device manager in Windows, it still shows my card as being up to date, working correctly and it shows the right version number for the drivers specifically (8.9110 or something like that)

One thing I noticed every time I do a new install of the drivers or the CCC, whether in the same pack or installed separately, I always get a message at the end that says "Finished with warnings, view log for details", but all the log tells me is that the various components of the pack installed correctly, CCC, drivers install manager, everything.

I'm really not sure what it could be in my settings that would make every install show me some kind of warning (that I can't even get access to). Could it just be a problem with version 11.11 since it was only released like a week ago?

I'm about to uninstall the drivers again, and then run driver sweeper and try to reinstall them after that. When I log back into windows after running driver sweeper, should I let windows run its own version of the driver updater, or cancel it and run the install pack I downloaded from AMD's web site right away?
m
0
l
November 24, 2011 7:55:09 PM

Success! I started with your suggestion netyoda, and it turns out it was a registry issue before anything else. I ended up having the same problem with one card as with two; ccc simply would not run when I managed to get it installed.

I read another thread showcasing similar issues and I followed some steps there that fixed my issue. So here are the steps I took to correct my issues:

1. With one gpu hoooked up, I uninstalled the drivers and rebooted.
2. Then I ran driver sweeper and cleared everything related to ati and rebooted
3. I installed ccleaner to clean up the registry by removing dead end entries from old installs (i also used it to clear 667 megs of junk and temp files: bonus!), then I rebooted
4. With one gpu connected, I disabled my antivirus, as I heard that can cause issues for ccc, then I ran the catalyst 11.11 ccc + driver pack and it installed correctly. I made sure to verify the driver number listed in windows device manager and the ccc
5. Then I rebooted to make sure the drivers were still there after a restart and they were (at last)
6. I then powered down my rig and plugged in the second 6870 card and set up the crossfire connection
7. I powered on and booted to windows, windows detected the device and the ccc gave me an auto prompt asking if I wanted to use crossfire settings so I said "go" and it turned crossfire on. I couldn't really tell at first, but since I use msi afterburner for fan control, I checked the gpu activity status by starting starcraft2 and sure enough, everything started heating up and using processing power, so that was it: mission accomplished!

Since then I've been fiddling around with how I want my fan settings to adjust to different gpu and temp loads, but everything is working great. Hardware status in he ccc shows main adapter and then linked device, win both running at pci x8, which is the dual card setting for my mobo so that's correct.

Anyway, there are the steps I too for anyone win similar issues; the main problem was that the driver install errors were a registry issue before anything else it seems. Hope maybe that'll help anyone with similar problems.
m
0
l
!