Sign in with
Sign up | Sign in
Your question
Solved

CPU not running at full speed

Last response: in CPUs
Share
May 7, 2012 2:11:35 PM

Hi,
While doing very CPU intencive tasks (Task Manager @100%), I fired up CPUID and found that my CPU is actually running ~800MHz instead of 2.4GHz.

Check it out: http://valid.canardpc.com/show_oc.php?id=2359711

Any idea how to fix this?

Cheers
Abdul

More about : cpu running full speed

a b à CPUs
May 7, 2012 2:22:58 PM

set your PC power plan to "high performance" in windows when you do heave workloads on your PC. There might be another issue, if you run heavy workload on your CPU for a long time, the CPU might get very hot and then "thermal throtling" kicks in and reduces your CPU speed to reduce the heat.

Best solution

a b à CPUs
May 7, 2012 2:23:42 PM
Share

Disable Intel SpeedStep in your BIOS and see how it goes.
Related resources
a c 184 à CPUs
May 7, 2012 2:40:57 PM

Keep it on though, it saves power.
May 7, 2012 3:03:06 PM

ilysaml said:
Disable Intel SpeedStep in your BIOS and see how it goes.


This made big difference, CPU Speed now went up to ~1600MHz, not bad, but still not 2.4GHz.
May 7, 2012 3:03:53 PM

Best answer selected by dman4x4.
July 12, 2013 7:43:38 PM

for some reason i have speedstep off and thermal throttle off and high performance mode on, but now it wont run 3.8 ghz on my i53570k, it used to a few days ago and nothing changed, pc is a shitty platfrom
a b à CPUs
July 13, 2013 3:36:24 AM

bigmike1 said:
for some reason i have speedstep off and thermal throttle off and high performance mode on, but now it wont run 3.8 ghz on my i53570k, it used to a few days ago and nothing changed, pc is a shitty platfrom

Disabling Speedstep you also disable "Turbo boost", witch ofc is a "C step". Before accusing the PC beying shitty you should check the part betweeen the PC and the chair :) 
!