Sign in with
Sign up | Sign in
Your question

DMA-high bench, terrible perfomance

Tags:
  • Hard Drives
  • DMA
  • Benchmark
  • Storage
Last response: in Storage
Share
Anonymous
a b G Storage
March 10, 2001 7:49:29 AM

Win 98 SE, Athlon 650, SD11, 128MB RAM,
Maxtor 91366U4 13.6 GB ULTRA DMA/66; 9MS SEEK; 2MB BUFFER; 7200RPM

I've had the system for a year, never been able to get the DMA to work properly, and have had DMA disabled. Finally got Sandra to confirm my suspicions: very low bench with DMA disabled. When I enable DMA (via Windows Device Manager), my benchmark goes off the charts, *yea*, but all software performs *terribly.* The whenever the drive is active, it goes into a 200 beats/min techno throb, the access light flashing along with it; the cursor skips around the screen; if I try to load a large audio file into sound forge, the system just hangs intermittently while doing it's 'throbbing' thing.

Hard drive is primary, cdrom is secondary; no slaves. I have DMA enabled on the CD ROM, but it's 62X and I'm not getting near the access rates I should with it.

I've read many of the posts here about getting the proper chipset drivers, and I believe I installed the 4 in 1 when I bought the system. I've had *numerous* other problems with this system, but everything else is working fine. This is the last big issue *praying*.

Many thanks in advance,
hawkeye

Class: IBM PC/AT

< Mainboard and Processor(s) >
Processor(s): AMD Athlon(tm) Processor @ 649MHz
Performance Rating: PR863 (estimated)
L2 On-board Cache: 512kB synchronous write-back
System Bus(es): ISA(16-bit), PCI(32/64-bit), USB, AGP(32-bit), SCSI
System BIOS: American Megatrends Inc. 62710
System Chipset: Advanced Micro Devices (AMD) AMD-751 CPU to PCI
Bridge
Front Side Bus Speed: 2x 100MHz (200MHz data rate)
Socket/Slot: Slot-A
Upgrade Interface: Slot 1/A
Supported Speed(s): 800MHz (or more)
Supported Voltage(s): 1.5V

< Cooling Device(s) >
CPU Fan Speed: 4856rpm

< Logical/Chipset Memory Banks >
Bank 0 Setting: 64MB SDRAM 8-1-1-1R 6-1-1-1W
Bank 1 Setting: 64MB SDRAM 8-1-1-1R 6-1-1-1W
Memory Bus Speed: 100MHz

< System Mainboard >
Manufacturer: FIC
MultiProcessor Support: No
Model: SD11
Version: 1.x
Serial Number: 00000000

< System BIOS >
Manufacturer: American Megatrends Inc.
Version: 62710
Date: 07/15/97

< System Memory >
Installed Memory: 128MB (96% true allocated load)
Number of Memory Slots: 3
Maximum Installable Memory: 1536MB
Maximum Module Size: 512MB
Supported Memory Types: DIMM, SDRAM
Supported Memory Voltages: 3.3V
DIMM1 (RASL-0 RASL-1): 128MB DIMM SDRAM double-bank
DIMM2: Empty
DIMM3: Empty

< Memory Modules >
Memory Module 1: American Computer & Digital Components 128MB
16x(8Mx8) SDRAM PC100-322-622 (CL3 upto 125MHz)

< Video System >
Monitor/Panel: Plug and Play Monitor
Model: StudioWorks 995E
Maximum Resolution: 1600x1200
Manufacturer: LG Electronics (GoldStar)
Model ID: 4A4C
Adapter: S3 Inc. Savage4 (Engineering BitFlip)
<< Diamond Multimedia Systems Stealth III S540 >>
< Device Information >
Device Type: VGA Display Adapter
Device ID: Device 5h on bus 2 F0
OEM Device Name: S3 Inc 86C394-397 Savage4
< Video Driver >
Model ID: s3_8.drv
Version: 4.11.01.8008
Supported Windows Version: 4.00

< AGP Bus >
Version: 1.00
Bus Speed: 67MHz
Current Data Transfer Rate: 2x (134MHz)
Side Band Enabled: Yes
Fast-Writes Enabled: No
Aperture Size: 512MB

< Drives and Storage Devices >
GENERIC NEC FLOPPY DISK: A: 1.44MB 3.5"

GENERIC IDE DISK TYPE47: C: 2.5GB, D: 1.9GB, E: 3.3GB, F: 3.4GB (11.2GB)
Drive Device: GENERIC IDE DISK TYPE47
Maxtor 91366U4 13.6 GB ULTRA DMA/66; 9MS SEEK; 2MB BUFFER; 7200RPM
Disk Controller: Primary IDE controller (dual fifo)
(E)IDE Device Configuration: Master
File System: FAT32

IOMEGA ZIP 100 : H: (Removable)
KENWOOD CD-ROM UCR-420 : G: (CD-ROM/DVD)
62X ATAPI; 6.75-9.3 MB/SEC TRANSFER RATE; LOW NOISE
Disk Controller: Secondary IDE controller (dual fifo)
(E)IDE Device Configuration: Master
DMA Transfers Enabled: Yes

< Peripherals >
Serial/Parallel Port(s): 1 COM / 1 LPT
USB Controller: VIA Tech 3038 PCI to USB Universal Host Controller
Keyboard: Standard 101/102-Key or Microsoft Natural Keyboard
Mouse: PS/2 Compatible Mouse Port
Game Interface: Creative Gameport Joystick

<< Advanced System Products ASC1300 SCSI Adapter >>
< Device Information >
Device Type: SCSI Mass Storage Controller
OEM Device Name: Advanced System Products ASC1300 PCI SCSI Host
Adapter (Fast Wide SCSI II)

<< Macronix International Co Ltd MX98715/25 Fast Ethernet Adapter >>
< Device Information >
Device Type: Ethernet Network Adapter
Windows Device Name: NDC 10/100 Fast Ethernet PCI Adapter (MX-A)[MX987x5]
OEM Device Name: Macronix International Co Ltd MX98715/25 Fast
Ethernet Adapter

< MultiMedia Device(s) >
Device: Creative SB Live! (Creative Labs CT4620 SBLive!)
Device Type: Audio Multimedia Device
OEM Device Name: Creative Labs EMU10K1 Audio Chipset
Device: M Audio Delta-66
OEM Device Name: IC Ensemble Inc ICE1712 Envy24 Multichannel Audio
Controller
Device: Creative Gameport Joystick

< Printer(s) >
Printer: HP LaserJet 6L PCL

< Operating System(s) >
Windows System: Microsoft Windows 98 Ver 4.10.2222 A
DOS Sub-System: Microsoft MS-DOS Ver 7.10 A

< Network Adapter(s) >
Networking Installed: Yes
Adapter: Dial-Up Adapter
Adapter: Network TeleSystems P.P.P.o.E. Adapter (NTSP3)
Adapter: NDC 10/100 Fast Ethernet PCI Adapter (MX-A)[MX987x5]

< Expansion Slots >
PCI1 (1h): PCI 32-bit 3.3V Shared PME FullLength InUse (Advanced
Micro Devices (AMD) AMD-751 PCI to AGP Bridge)
PCI2 (2h): PCI 32-bit 3.3V Shared PME FullLength Available
PCI3 (3h): PCI 32-bit 3.3V Shared PME FullLength InUse (Creative
Labs CT4620 SBLive!)
PCI4 (4h): PCI 32-bit 3.3V Shared PME FullLength InUse
AGP (8h): AGP-2x 32-bit 3.3V Shared PME FullLength InUse

< Temperature Sensor(s) >
Board Temperature: 23.7°C / 74.7°F
CPU Temperature: 23.7°C / 74.7°F
Power / Aux Temperature: 24.5°C / 76.1°F



Never cut what you can untie. -Joubert (1754-1824)

More about : dma high bench terrible perfomance

March 10, 2001 11:23:28 PM

I've heard that a lot of Maxtor drives have this problem after a while. You might just be out of luck, but you could try a few things.

1. set your virtual memory to 0 MB
2. defrag your hard drive and reboot
3. set your virtual memory to 256 MB max and 256 MB min
4. reboot

This will defrag your hard drive and minimize any further fragmentation. It might not fix your problem, but it's worth a shot.

Really love your peaches wanna shake your tree.
Anonymous
a b G Storage
March 11, 2001 9:54:12 AM

no dice. Same problem still with me.

Just to give you an idea, with DMA disabled, Sandra says:

drive index 6614

which is (apparently) comparable to an EIDE UDMA drive, and far short of UDMA 33 or 66. This is with a completely defragged drive. When I enable DMA in Windows, Sandra says

drive index 15495

which is considerably better than the listed drive index for a UDMA 66 drive. But, I get the consequent 'throbbing drive' syndrome, so the benchmark doesn't mean much; i.e., my computer is essentially useless.

??Do you mean to say, though, that you think there's a problem with the dirve itself? It's under warranty for a few more years! I have been (why?) assuming that the drive is fine; it "works", it's just really slow.

I haven't done any other obvious thing, like change out the UDMA cable (it's spec and came with the drive; it's installed correctly), and my BIOS PIO is set to 4. I've had other problems that suggest a fouled BIOS, but have been reluctant to flash (if it ain't *broke*...). Could it be that the BIOS is improperly setting my drive to the wrong PIO? The benchmark is strikingly similar to the UDMA 0 benchmark. I've also read in various places that you don't need to enable the DMA setting in Windows to get the UDMA functionality; i.e., that the OS has nothing to do with UDMA capability, that it's all in the chipset?

Why do you think it's the actual hd that's bunk? What would be wrong with it?

Never cut what you can untie. -Joubert (1754-1824)
Anonymous
a b G Storage
March 11, 2001 4:46:03 PM

you should not be using PIO for UDMA tranfer modes.. If the bios is not recognizing the drive as a UDMA drive, that is the beginning of your problems.

***check the jumpers 1st then check em again***
March 12, 2001 1:32:12 AM

Absolutely!!!

Your BIOS and OS will work against each other to do some marvellous things.

I even had a maxtor drive disabled on BIOS once, but 2K still found it and used it (with errors)...

Set your BIOS to Auto or UDMA4/5 (66/100) as appropriate and fly free.....

Good luck,

Pete.

-Your Comany Names Could Be Here-
e-mail for application details.
Anonymous
a b G Storage
March 12, 2001 6:39:59 AM

thanks very much for all the advice, but still no dice.

I went in and individually tweaked the various HD settings in the BIOS, changing first PIO to auto, then the entire HD category to auto. Nothing helps. The post is detecting my HD as being UDMA 4, but there's no option within the BIOS to actually change the UDMA setting. I went back and double checked that the mobo does actually support UDMA 66, and it does (FIC SD-11).

It needs to be said that my BIOS is acting very strangely. If I want to make any changes to any of the settings, I first have to "reset" all of the settings by loading one of the default groups of settings from withing the BIOS setup. Then I have to go and individually change all the necessary tweaks I've had in place back to what they were, and finally change the individual test setting at hand. If I don't, my CPU speed slows to that of a 166 or so; my system essentially grinds to a hault.

Also, when booting Windows I also have problems on a very regular basis (who doesn't, right? well, not like this). The hang usually occurs near the end of the boot process, after my wallpaper loads, but before my desktop icons appear. This would indicate, maybe, a problem in the PlugNPlay functionality, and sure enough, the hangs usually happen after I've changed some system settings or added/removed some hardware. To give you an idea, each time I change a BIOS setting (after the excruciatingly slow procedure outlined above) I can expect to reboot 1-4 times before I actually get a desktop. Lotsa fun. It's always been like this, I've reinstalled a few times with no apparent difference.

I'm pulling up my britches, and getting ready to flash the BIOS. I'm not convinced it's necessary, but I'm running out of options, and it's kinda old (10/99--SD11 v. NC605). Any thoughts????


Never cut what you can untie. -Joubert (1754-1824)
March 12, 2001 7:48:00 AM

Okay,

From a bios perspective - it sounds like you have some issues.

Enabling auto device in Bios for the IDE should be okay. Is there a PIO/DMA setting for the devices under bios too?

Not same board, but DMA is something I set on the IDE channel control under Win2K devices. (Not the disk device).

Sounds like a new bios try fisrt (has it always done this or is it a new development?).

Also are you over-tweaking your board? It seems that disc controllers are the first things to go on mine when I start 'tuning'. Get reboots as system initialises etc.

Other than setting CPU speed - is your PC more stable at default, no shadowing, prefetch, memory tweaks, etc?

Alternatively - by a cheap promise ATA66 or 100 PCI card, disable your onboard IDE totally and boot from the card. I read this uses less resource (1 IRQ) and can be prefereable...


Up to you - try the bios first?

Later.

-Your Comany Names Could Be Here-
e-mail for application details.
March 12, 2001 1:49:57 PM

Try checking these Doc's on Microsoft's Web site:
Q258757
Q159560

The way I see it is your BIOS is seeing it correctly as DMA mode 4 and NOT PIO, other then that sounds like an OS problem.

Lars Coleman<P ID="edit"><FONT SIZE=-1><EM>Edited by Lars_Coleman on 03/12/01 09:52 AM.</EM></FONT></P>
March 12, 2001 8:52:44 PM

Go to www.viahardware.com and download the latest IDE Busmaster drivers for VIA chipsets. They claim to improve performance greatly, especially the latest versions, so you might give it a shot.
Anonymous
a b G Storage
March 13, 2001 7:57:25 AM

Sorry about the long posts, but the devil is in the details (even if no one pays attention to them). I read the microsoft articles as you suggested. Here's what I think I've learned from the first article:

microsoft:
"How to Enable DMA for a Hard Disk
If you are using Windows 98, Windows Millennium Edition (Me) or a version of Windows 95 that includes DMA support, DMA is already enabled for your hard disk by default.

Determine if DMA Is Enabled on Your Computer
By default, DMA is enabled for hard disks on Windows 98-based and Windows Millennium Edition-based computers, but it is enabled only with some specific versions of Windows 95 that are listed below."

also, from the maxtor udma faq:

"Q04: Are there any special system or software requirements to use an Ultra DMA drive?
A04: Yes as follows:

4. Windows 95B and Windows 98 have LIMITED driver support, however Operating Systems (OS) do not normally include the UDMA drivers, as the OS does not have any direct control over this operation. If the motherboard provides the chip sets and the drivers are installed, after the OS, then the system will *automatically* [my asterisks] utilize the maximum data transfer rate possible when transferring data between RAM and the hard drive."

This suggests that I wouldn't have to enable DMA (note the distinction, UDMA v. DMA) for my harddrive, because I'm using win98. Now then, why is there that obvious checkbox in the device manager?

Which gets me to the second article, about the DMA checkbox not staying checked. If I check it, it stays checked and causes all hell to break loose in my system; it causes the 'hd throb' which I've described above. So, my DMA checkbox somehow becoming unchecked is not the problem.

I've long wondered about the DMA setting in the win98 device manager. Are DMA and UDMA the same thing? What, exactly, is the relationship between DMA, UDMA, and PIO? One practical thing could at least help: if there's someone out there with Win98 and a UDMA 66 hd, someone who *knows* (like with a benchmark) that it's functioning to spec, can you tell me: do you have the DMA setting in the windows device manager enabled??

As for the via busmaster drivers, it's no less confusing. I have long since installed the via 4in1 driver pack as recommended on the via website. I was confused by this tidbit from the README:

v. 4.25(1)
"About VIA 4 In 1:
VIA 4 In 1 driver includes four system drivers to improve the performance and maintain the stability of system using VIA chipset. These four drivers are:
VIA Registry (INF) Driver, VIA AGP VxD driver, VIA ATAPI Vendor Support Driver and VIA PCI IRQ Miniport Driver. For Windows NT users, VIA IDE Bus Mastering driver is only driver to be installed to your system."

This suggests that there is no bus mastering update in the 4in1 for anything but NT/win2k, which is odd because via recommends always using the 4in1. So I downloaded the *latest* bus mastering driver update. It's readme says:

v. 580_2150(3)
"VIA Bus Master(Ultra DMA) PCI IDE Driver ReadMe.Txt for Win9x/WinNT."

Which suggests that the bus mastering driver *is* for win98. Anyhow, I installed the driver: win98 hangs during the boot process while trying to load the myriad windows drivers. I tried various BIOS tweaks, tried enabling DMA in windows, nothing worked, couldn't boot, had to uninstall the busmastering driver in safe mode.

The good news is that I am turning into a hardware finatic. I can't wait to learn the next detail about ata eide dma udma pio. I've sent an email to via tech support with little hope for a helpful reply. Any thoughts? Won't some guru out there take pity on a poor soul?

Never cut what you can untie. -Joubert (1754-1824)
Anonymous
a b G Storage
March 14, 2001 2:53:13 AM

"Determine if DMA Is Enabled on Your Computer"

Devil is in the details. This also means making sure your bios is setting the transfer mode of the drive in some DMA mode. (whether that's an earlier type such as multiword DMA mode 0,1,2 or a new Ulra DMA mode). After this for Win98/ME, it will usually automically check the DMA box if the bios has done so. Not always (there's always an exception), but it should.

Everything else you've said is still related to the OS. Don't focus on that. You need to focus on getting the bios to set the drive in UDMA mode first. Probably the rest will work itself out once you solve that.


***check the jumpers 1st then check em again***
Anonymous
a b G Storage
March 14, 2001 2:31:40 PM

Chord, many thanks for the patient, steady guidance.

I checked system properties > device manager > computer properties > view resources > DMA

There are 4 channels listed

1 SB Live SB 16 Emulator
2 Standard Floppy Controller
4 DMA Controller
5 SB Live SB 16 Emulator

I'm not sure how to interpret this. Is it ok or not?

The check box in system properties > device manager > GENERIC IDE DISK TYPE47 Properties is *not* checked.

To reiterate, if I pause during POST, the screen displays:
PRI MASTER Maxtor 91366U4
ULTRA-DMA MODE-4, SMART capable but disabled.

Doesn't this mean that the BIOS *is* setting the transfer mode of the drive in the proper DMA mode?

In my BIOS, I have:
LBA On
BLOCK On
Fast Programmed I/O Mode Auto (choices Auto and 0-5)
32 bit transfer On

There is no DMA/UDMA option in the BIOS.

I also did the "debug" suggested in MS article Q159560, "To determine whether your IDE hard disk supports multiple-word DMA protocol." The test went fine, came up 00, no problem there.

still no solution. Should I flash? Is there some setting I'm missing? Thanks to everyone for all your patience and help.

Never cut what you can untie. -Joubert (1754-1824)
Anonymous
a b G Storage
March 15, 2001 2:32:17 AM

>>To reiterate, if I pause during POST, the screen displays:
PRI MASTER Maxtor 91366U4
ULTRA-DMA MODE-4, SMART capable but disabled.<<

Ok and you are using a UDMA 66/100 cable that has 80 wires 40 pin outs? If you are, the below may be the problem. Taken from the FIC FAQ on the SD11.

""Q:When I connect the Hard Disk with UDMA33 cable, it works properly. But when I'm using UDMA66 cable, and check Using DMA checkbox, the system is unstable and causes a lot of disk problems. (When I uncheck the DMA checkbox, the system works properly). With Windows 98, 98SE, ME, 2000 the same problem occurs when I attempt to use the DMA option (and I have installed and uninstalled almost all of the VIA patchs...). What's the Problem? My HD is a Maxtor 51536U3. (2000/7/4)

A:SD11 has hardware limitation working with Maxtor ATA/66 HDs in UDMA66 using DMA transfer mode. FIC has a beta BIOS, the NC6060 to auto drop the DMA transfer mode to UDMA33 and prevent system corruption while files are copied between IDE devices. The new BIOS also updates CPU ID for the AMD Athlon 700 (.18 TBird). HDs sized over 33GB report size error if set at auto. ""

<A HREF="http://www.fic.com.tw/techsupport/faq/faqs01SD11.htm" target="_new">http://www.fic.com.tw/techsupport/faq/faqs01SD11.htm&lt;/A>

If you are not, it still poses a problem as you can not operate in UDMA mode 4 or 5 without it. So if you are not, try the cable and see if the problem goes away. If it doesn't, you might try the beta bios suggested above in the faq. I don't know of a Maxtor utility that will allow the bios to detect it as an ATA33 drive nor do I know of jumper setting that would allow this (don't look to hard, because I seriously doubt there is one. Many bioses allow you to manually set this transfer mode.. So put another mark in the "CONS" column for this AMI bios if it's the case that you can not. The above FAQ answer would have me leaning toward the ability that you can change from AUTO to manually selecting the transfer mode) Lowering it to ATA 33 would not show any significant decrease in performance.

Your other option is to use an ATA 66/100 controller card, which can be had for 20-30$.

***check the jumpers 1st then check em again***
March 15, 2001 11:56:18 PM

how do you disable on-board ide controller?
I have bios as AUTO mode, how do you set bios to see a specific drive ? I used user or custom mode and it didn't work.
March 16, 2001 12:15:54 AM

Hi,

My bios has an option to enable disable IDE 1/2.

If that fails, I'd recommend setting all IDE device types as none (yours is auto you said) and disabling the hardware device under windows device manager.

Of course this isn't recommended if you are booting off a disk on that IDE channel :o ).

-Your Comany Names Could Be Here-
e-mail for application details.
Anonymous
a b G Storage
March 20, 2001 9:37:03 AM

Hallo friend
you seem to be having the same problems as me.
the only other thing i tried was to change my ide cable
now i use the old ata 33 cable and my pc performs far better
read/write has gone from 4mb/s to 16 mb/s .this makes an enourmous difference in performance.

byt the way dma enabled or not makes no difference on my system. kt7 + maxtor 20 gb

may be worth a try

I want a tbird
Anonymous
a b G Storage
March 26, 2001 12:30:48 AM

Well, first, thanks to everyone, again, for all your good advice, help, and time.

Chord, wow, you found exactly the faq item I should have found. I'd been looking on the FIC "USA English" site which doesn't list this conflict, so I never came across it in all my digging there. AAARRRRG.

I finally got a different IBM hard drive, UDMA 33 unfortuately (I wanted to test the UDMA 66 capability with a drive from a different manufacturer). Anyhow, I hooked up the drive, formatted it, and installed Win98 in about 20 minutes. The previous installation on the Maxtor took me almost 3 weeks. So, I concluded that the maxtor/sd11 UDMA 66 mix is probably to blame for the general instability/poor performance of my system, as the faq said.

Strangely, since I hooked the Maxtor UDMA66 drive back up, the frequent and predictable boot crashes have disappeared. There's been a "screen" added immediately following POST which allows me to select "boot from IDE," or "boot from cd-rom." This was never there before, and seems to be the result of some interaction between the BIOS and the clean install of win98 I did on the *other* harddrive. Weird. Anyhow, no more crashes at the end of my boot process. heehaw.

Unfortunately, the drive is still performing very slowly. I went and found a UDMA 33 cable, as superlex and Chord suggested, but this hasn't made any difference, and the drive still benchmarks at a 6610 drive index with Sandra, about that of a UDMA 0 drive. I still have a few tests to run, and especially want to load Sandra onto the UDMA 33 drive, and see what happens there. Haven't gotten to it yet.

To confirm, Chord, there is no option to set the UDMA in the current BIOS. I've opted not to try and flash with the "beta BIOS." I have only one computer, and it needs to be running . . . I'm in the middle of building another system, and when it's up, I may get the guts to flash, but for now, I don't want any part of this Beta thingy. yeeps.

I think the simplest thing will be for me to get a new, non-Maxtor hd at some point. I can always use a new hd anyhow, and so it won't be that big a deal. No empty PCI slots at this point for a card. By then, this poor computer's gonna be my web server.

That's it for now. I'm gonna leave well enough alone until I get the $ for a new drive. Thanks again for everyone's thoughtful advice, especially Chord for sticking with me even though I clearly lack experience with this stuff. Many thanks! I'll be lurking : )

Never cut what you can untie. -Joubert (1754-1824)
!