Game stutter problem

I built a new pc and have had it for about a month or two. Games are stuttering on high and low settings. I swiped old drivers, reinstalled, didn't work. Swapped out my 6870 with a friends 6870 and fixed the problem first go around, restarted computer and problem began again. Reinstalled drivers again, didn't fix it. Could it be the processor or mobo?

System specs:
AMD Phenom II X6 1100t
G.Skill Ripjaw Series 8GB DDR3 1333 (2x4GB)
Asus 6870
Sabertooth 990FX
Antec NEO ECO 620W
WD Caviar Black 1TB
Windows 7 64-Bit
11 answers Last reply
More about game stutter problem
  1. What games does this happen with?
  2. Every game I've tried so far including GTA IV, GTA EFLC, and Skyrim.
  3. I had this same problem before and it progressed to freezing on a brown, blue, purple, etc screen.. ended up being the power supply. It could be you latency though.
  4. okigeek said:
    I had this same problem before and it progressed to freezing on a brown, blue, purple, etc screen.. ended up being the power supply. It could be you latency though.

    What do you mean by latency? And this only happens in game, I have no problems out of game at all so I don't understand why it would be the power supply. Did you start having problems only in game?
  5. by latency if you are playing online it could be your connection. i am not an avid gamer and by no means an expert but if your internet server ping rate is higher it can cause the game to stutter. And yes all my problems started and were only in game initially with WoW then DeusEx and CoD BlackOps.
  6. i say all that but take into account also that i am now replacing a mobo. i wouldn not go out and buy a psu just because i said i had that problem.
  7. Its not network related, these problems are occurring during single player.
  8. Can you give a rundown of all 3D settings you have enabled and set in CCC? Also when you reinstalled the drivers how did you go about doing that? You may want to use one of AMD's driver removal tools to make sure everything is removed after you do the normal uninstall proceedure.
    http://downloads.guru3d.com/download.php?det=1275 <- try this one OR
    http://www.guru3d.com/category/driversweeper/ <- this one

    Also remove and delete the driver that windows has associated through device manager and click the accompanied checkbox for "delete driver software".

    Give that a shot and let us know how that goes
  9. airsoftsoldrecn9 said:
    Can you give a rundown of all 3D settings you have enabled and set in CCC? Also when you reinstalled the drivers how did you go about doing that? You may want to use one of AMD's driver removal tools to make sure everything is removed after you do the normal uninstall proceedure.
    http://downloads.guru3d.com/download.php?det=1275 <- try this one OR
    http://www.guru3d.com/category/driversweeper/ <- this one

    Also remove and delete the driver that windows has associated through device manager and click the accompanied checkbox for "delete driver software".

    Give that a shot and let us know how that goes


    CCC 3D Settings:
    Anti-Aliasing, standard
    Anisotropic Filtering
    Tessellation, AMD Optimized
    Surface Format Optimization Enabled
    Wait For Vertical Refresh, 2nd Line, Off, Unless application specifies
    Anti-Aliasing Mode, Performance
    Triple Buffering is Unchecked

    As for the drivers, I uninstalled them normally then ran a third party program to delete them, then reinstalled with no luck. I'll give Guru3D a shot.
  10. AMD released new drivers today, did the same process, uninstall, install, and same thing. All games worked first go around, then when i restarted my pc, the problem began again. So it works fine when fresh drivers are installed, but when I restart, it goes back to the way it was. Any ideas?
  11. still having problems, any ideas?
Ask a new question

Read More

Homebuilt Games Systems