Sign in with
Sign up | Sign in
Your question

XP problem accessing net via travel router

Last response: in Networking
Share
February 13, 2011 2:30:20 PM

I'm using a Trendnet TEW654TR travel router in a hotel in the Middle East. It's wired into the net connection in my room. I have a laptop working fine with it, running Windows XP SP2 and connecting over 802.11g. It acquires an IP address in the 10.*.*.* range, which is assigned by the hotel network.

My other laptop can connect to the Trendnet, but cannot connect to the internet. It's also running XP SP2, and when it connects to the Trendnet router it acquires an IP address of 192.168.10.* from the Trendnet router (the router's address is 192.168.10.1). It has no internet connectivity, although it can connect to the admin console of the Trendnet router. It cannot ping IP addresses on the internet.

The problem laptop is an Acer Aspire 5050, with a Broadcom wireless adapter. I've tried using both the Broadcom Wireless Utility and the native Windows wireless manager and both give the same result.

Can anyone help??
Anonymous
February 13, 2011 4:26:31 PM

Check TCP/IP Properties.

Start, Connect To, Connection, Properties, Scroll Down TCP/IP and highlight, click Properties and check that Obtain DNS and IP address automatically are enabled.
February 13, 2011 11:17:23 PM

Something doesn't make sense here. If both laptops are using the travel router as a router/AP, then how can both be connected to the travel router, but one using the 10.*.*.* range, the other 192.168.10.* range? Presumably the travel router has its own DHCP server and is handing out IPs in the 192.168.10.* range to all comers. So where is this 10.*.*.* coming from? Sounds to me like the laptop is perhaps connected directly to the hotel's wireless network, whereas the travel router isn't. Is it possible the hotel uses a web portal for authorization and the travel router can’t handle it?
Related resources
February 14, 2011 6:46:25 AM

The problem laptop is set to obtain IP address and DNS servers automatically - the TCP/IP settings are configured identically to the "good" laptop.

I'm guessing that the "good" laptop is getting the 10.*.*.* IP address from the hotel's DHCP server. It must be doing this via the Trendnet router as there are no other wireless access points within range (I have scanned using the Intel Wireless utility). Here's what IPCONFIG shows for this laptop:

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . : kattive.local
IP Address. . . . . . . . . . . . : 10.100.121.65
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . : 10.100.255.254
Anonymous
February 14, 2011 7:35:39 AM

These hotel and cafe guest setups often use two addresses (perhaps 2 routers, I don't know). One public which you log into and a second which you get into when you register/pay. Could that be the cause. May be worth looking at proxy setting in Windows Networking.
February 14, 2011 11:55:59 AM

I skimmed the manual for that router just to double-check its features. From what I can see, it's possible to configure it in two ways relevant to your circumstances -- AP Mode or Router Mode.

In AP Mode, your wireless clients grab their IP addresses from the hotel's DHCP server (10.x.x.x.), at least they should. In Router Mode, your wireless clients grab their IP addresses from the travel router's DHCP server (192.168.10.x). But I noticed a potential pitfall here.

Normally you would have the travel router’s DHCP server DISABLED when configured for AP Mode. Again, you probably want your wireless clients to obtain their IP settings from the hotel under these circumstances, not the travel router. But if you have the travel router’s DHCP server ENABLED, you have a potential problem. It’s then a toss-up which DHCP server (the travel router’s or the hotel’s) responds first to DHCP requests! IOW, it’s entirely possible to have DHCP requests fulfilled by either DHCP server because you have access to *two* DHCP servers on the same network (a big no-no).

Now granted, I’m guessing here about what could go wrong. But that’s the only way I could see that two wireless clients to the same travel router could have different IP ranges. Of course, if you renew their respective leases, they might switch IP ranges, or both end up on the hotel’s IP range, or both end up on the travel router’s IP range. Again, it’s pure luck which DHCP server responds first. The fact that one of the laptops obtains an IP address from the travel router (192.168.10.x) but has no internet access strongly suggests the travel router is in AP Mode and has (wrongly) DHCP enabled.

So either you have to use AP Mode but leave DHPC disabled, or even better, use Router Mode (DHCP enabled). The potential problem w/ Router Mode, however, is if the hotel is using a web portal for authentication, it might make Router Mode impossible since obviously the router has no means to process that request. But if that’s not the case, Router Mode is the better option.


Anonymous
February 14, 2011 12:00:03 PM

It occurred to me that the hotel's system may be designed not to permit a router to be attached (or more than one computer via it).

I've seen posts on that kind of issue in university accommodation where the rule is strictly one computer per room.
February 21, 2011 7:49:52 PM

Quote:
It occurred to me that the hotel's system may be designed not to permit a router to be attached (or more than one computer via it).

I've seen posts on that kind of issue in university accommodation where the rule is strictly one computer per room.


I think this may have been the case. After a while I finally got the 2nd laptop to connect to the internet, but then I was unable to re-connect the original laptop to the net. It seemed as if the hotel would only permit one DHCP lease from the ethernet port in the room.
February 21, 2011 10:43:40 PM

itm said:
I think this may have been the case. After a while I finally got the 2nd laptop to connect to the internet, but then I was unable to re-connect the original laptop to the net. It seemed as if the hotel would only permit one DHCP lease from the ethernet port in the room.


This is only going to matter if you configure the travel router in AP Mode (something you never responded to when asked, are you using Router Mode or AP Mode?). The whole point of Router Mode is to share a single IP from the ISP's subnet (10.x.x.x, you can think of the hotel as the ISP in this case) with multiple clients behind the router, all of whom get their IP assignments from the router’s subnet (192.168.10.x). Again, that’s the whole point of using a router!

But instead, one of your clients is getting an IP assignment from the hotel’s subnet (10.x.x.x), the other from the router’s subnet (192.168.10.x). That makes no sense. It should be one or the other, not both! As I said in a prior post, this raises the possibility you have the router in AP Mode (which explains one device getting the hotel’s subnet), while (erroneously) leaving the router’s DHCP server enabled, which explains why the other might be assigned an IP in the router’s subnet.

Before you can ever straighten out a problem like this, you have to be properly configured. You should normally be using Router Mode w/ DHCP enabled. The WAN port of the travel router should then be assigned an IP address from the hotel’s subnet (10.x.x.x) and never seen by the clients behind the router. The clients should only see the router’s subnet (192.168.10.x).

The only time you wouldn’t use Router Mode is if the hotel uses a captive portal, something the router can’t handle (e.g., a signon page). In that case, you must use AP Mode *and* disable DHCP. Now the router is just a WAP (wireless access point) and DHCP requests are passed through to the hotel. Clients now receive IP assignments in the hotel’s subnet (10.x.x.x) and handle their respective captive portals. Of course, ***now*** you run into the possibility the hotel is limiting IP assignments. But if you were properly configured, the device that could NOT get connected would NOT have an IP address from the router’s subnet (remember, that DHCP server is supposed to be disabled in AP Mode!), but rather a self-assigned IP address in the 169.254.x.x subnet.

The reason that’s an important point is that if the router is in AP Mode w/ DHCP enabled, you can’t really tell if the hotel is limiting IP assignments because there are now *two* DHCP servers active on the network (the hotel and yours). It’s entirely possible that sometimes your router’s DHCP server is responding before the hotel, and as a result, misconfiguring one of your clients. Had the router’s DHCP been disabled, that second DHCP request might very well have been accepted and provided an IP address from the hotel’s subnet. IOW, your errant use of your own DHCP server in AP Mode makes it impossible to know w/ any certainty whether the hotel is or isn’t limiting IP assignments.
March 1, 2011 8:24:18 PM

Thanks for your reply. I did indeed have the Trendnet in AP mode, but also tried disabling DHCP.

There are 2 options in the LAN settings on the Trendnet - these are the descriptions from the product manual:
(a) LAN Connection is Dynamic IP (DHCP) - to obtain the IP address information automatically from your ISP. The IP Address, Subnet Mask, and Gateway Address are shown on the page

(b) LAN Connection is Static IP - if you are required to use a permanent IP address to connect to the Internet. You need to manually enter the information provided by your ISP.

I tried both. In scenario (a) I got the problem that you refer to - i.e. the Trendnet was able to connect to the hotel network and pick up a dynamic IP address, but only one laptop could pick up a 10.*.*.* IP address on the hotel network via the Trendnet. The other laptop picked up a 192.168.10.* IP address from the Trendnet DHCP server and wasn't able to connect to the hotel network.

In scenario (b) (DHCP disabled) the Trendnet wasn't able to connect to the hotel network at all, nor were either of the two laptops. Presumably this is because, based on the text from the manual above, the Trendnet was not configured to accept a dynamic IP address from the hotel network - i.e. it required a static IP address which of course I wasn't able to give it (as the IP addresses could only be allocated by the hotel network).

The hotel had a login page, so presumably this would have prevented me from using Router mode.

???
!