Sign in with
Sign up | Sign in
Your question

New Mini-ITX build won't even boot (cannot see POST)

Last response: in Systems
Share
January 26, 2012 12:23:14 PM

Parts used:
Compucase Mini ITX Case - With 120W PSU and Front panel USB2.0 HD Audio
Intel D525MW Atom D525 1.66GHz VGA Out Mini-ITX Motherboard
2x Kingston 2GB DDR3 1066MHz/PC3-8500 Laptop Memory Sodimm CL7 1.5V
Maxtor Diamondmax Plus 9 - 80GB 7200RPM SATA I 3.5" Internal HDD 6Y080M0

Doesn't boot, doesn't even POST, and just sits there, power light flashing.

More about : mini itx build boot post

January 26, 2012 3:15:40 PM

first of all what have you tryed to get it to boot.
January 26, 2012 3:24:47 PM

Problem solved, now. and to answer your question, it just couldn't boot. It wouldn't do anything.
April 12, 2012 10:50:11 AM

What was the fix?
I have a new D525MW with 2 x 2GB Corsair 1066 Memory (CM3X2GSD1066) and it wont post.
I've tried removing all unrequired devices and booting with only one stick of memory with no luck.

Any help would be appreciated.
!