Sign in with
Sign up | Sign in
Your question

I7 3770k wont post, out of ideas!

Last response: in CPUs
Share
May 9, 2012 4:23:28 PM

Hey guys, about an hour ago I just installed an i7 3770k into my old system that was previously running a i5 2500k. After putting it back together it just wont post. The only thing I swapped around was the cpu (and added a d14 cooler instead of the standard on the i5 had). I get a memory error on the motherboards led readout "55". It was running 4x4gb sticks of corsair xms3 ddr3 1333 with the i5, but after seeing the error message I swapped single sticks into each slot to try eliminate the ram as being at fault (i even tried my kingston hyperx 1600 sticks to be extra sure!). Other things I have tried is resetting bios, removing battery, removing every hdd/ssd/optical drive and even trying to boot without mouse/kb etc. It still pops up an error 55 (memory issue). the only thing I didn't try yet, is reinstall the old i5 to see if its 100% the new cpu causing this to fail (the thought of taking out the board and cooler makes me sad). I also tried to install the latest bios version via usb, but as I cant post, I can't get it to install. Any ideas before I need to strip out the cooler and try the old chip?

Some additional information about the system...

asus p8z68 deluxe (non gen3) I forget the current bios version but I'm leaning on this being out of date for the new ib chips
4x 4gb corsair ddr3 1333
xfx dual fan 6950 2gb x2 (tried with one)
2x60gb ocz vertex III ssd
2x 2tb storage (not plugged in at the moment)
ocz zt750watt psu

More about : 3770k wont post ideas

May 9, 2012 4:46:26 PM

And what is wrong with that? wom't make a single difference to my system performance going 77 as far as I know...

New motherboard will be an option later on when I upgrade my cards but I doubt I will see any real gains?
May 9, 2012 4:55:38 PM

just popped the i5 back in and it posted just fine, so I guess either the bios is outdated or the board doesn't like the ib chip (although the asus site says its compatible). I will update when I try update bios and try the ib again.
Related resources
May 9, 2012 5:37:22 PM

asus z68 boards do happily take ivybridge cpu's, but do need latest bios for them to work.
this is bios you need, P8Z68 BIOS 3801, grab it from there website.
May 9, 2012 5:58:25 PM

Well, its all sorted now. I guess I should have updated the bios BEFORE I installed the i7! I just had to swap in the i5 to get into bios to install the latest version via usb drive. All thats left is to install windows, then I can build up the next pc from the bits I have aquired over the last couple of months!
May 9, 2012 8:02:04 PM

Now I have an issue inside windows, it seems somethings not quite right with the chipset drivers and this cpu, got "pci simple communications controller, universal serial bus controller" and some "unknown devices" in my device manager. I'm assuming one of these is my sata dvd writer, as its not showing up in windows. I tried to download everything from the asus site, but nothing seems to shift this missing driver issue. Any ideas anyone? I'm 100% sure its down to the cpu, as it all worked fine with the i5
May 9, 2012 9:34:49 PM

Cheers again! It turned out the cd-rom didn't like the sata port I was using. Either way its all sorted now! one of the missing items in device manager was the cd-rom, the other seemed to be my onboard bluetooth!. I logged into wow after a mild overclock and I'm seeing around a 20-40fps boost over the i5 2500k at a slightly lower clock so for my fave game its a boost. Will try cs6 and premiere later. Next up, I need to play around with a ramdisk and see how long it takes before I break something. Thanks again guys for all your thoughts and ideas! Great forum.
!