Sign in with
Sign up | Sign in
Your question
Solved

I have an Corsair H100 liquid coolong pump and i crossed molex leads

Last response: in Components
Share
May 10, 2012 3:27:55 AM

I was doing some work on my computer and the molex plug that went to the liquid cooling pump was a two pin molex connector however the connector got loose and appearantly fell off, I straightened the leads out and put the connector back on as best i could however i accidently crossed the leads and i ended up plugging the CPU cooler in backwards. Upon turning the computer on i smelt a burnt smell and post immediately went crazy with a fan problem warning. I turned off the computer switched the leads and tried again same thing.. I am terrified i damaged something more than the CPU coolers. Is that possible? Could i have damaged my motherboard or the powersupply or the CPU , etc..... I am totally scared and paniced

Best solution

a b ) Power supply
May 10, 2012 7:07:17 AM

Hello,

From what I understand, the 2 wires fell off the Molex connector for the pump of your H100. You put both of them back in the plastic shell, but inadvertently inverted them : For example, you replugged the one that was on the left to the right and vice-versa.

From that, I gather that many different things could have happened :

1. You short-circuited your PSU, which in turn short-circuited your entire PC, which could now be completely dead.
2. Only the PSU was short-circuited. You would need to find a new one.
3. Only the H100 was affected. Having inverted the wires made it so that the pump and the fans connected to it started backward, which damaged it completely.

The first thing I'd do is put another PSU in your PC and see what it does. If it starts normally, go in the BIOS and check your temps. If everything is ok, then it was simply the PSU that was damaged.
If replacing the PSU does nothing, then there's a greater risk that the entire motherboard was short-circuited.

Good luck,
al360ex
Share
July 12, 2012 6:17:13 AM

Hey I just had a similar problem happen to my computer. I was cleaning up some of my loose wiring in my case and I unplugged the molex connector form my H100. I also panicked and because I couldn't remember where the plugs went. I tried a few different configurations but noting worked. I called corsair and they said it was a common problem and that it would be best to return the H!00. If you are past your return date then corsair will cover it under their 5 year manufacturer's warranty. I don't think you shorted your board or PSU. Mine comp is running fin right now. I just had to install the intel stock fan while I am waiting for my new H100.
m
0
l
a b ) Power supply
July 12, 2012 2:20:46 PM

That's quite an old thread you resurrected there !
m
0
l
August 3, 2012 9:04:32 PM

Yes corsair helped me out as well
m
0
l
August 11, 2012 12:56:01 AM

Best answer selected by Alpha90.
m
0
l
!