Sign in with
Sign up | Sign in
Your question

TX850 PSU not compatible?!

Last response: in Systems
Share
January 27, 2012 8:36:26 AM

Ok long story short. I built a PC a few months ago. Specs:

i5 2400
GA-Z68XP-D3
Corsair Value pick or something like that 1333mhz 2x4gb
Corsair force 3 60gb ssd
WD Blue Caviar 500gb (from old computer)
Antec BP500u

100% fine.

1 week later I added a Powercolour HD 6790. Problems... White/grey stripes while gaming. Got a TX850 (thought I needed more power). Bad reading in HW monitor (2volts on 12v rail and I still got grey stripes while gaming). RMA'ed the TX850. Same readings in HWmonitor. Reinstalled windows. Computer now takes a dump every 5 minutes. All drivers/firmware are up to date. I try to set the theme to aero and at the EXACT moment i click aero, it black screens. Did it a few more times and it keeps black screening. It also bsod at within 10 minutes of start up. I left a sticky not on the desktop and the I tried to shut down and at the moment I clicked shutdown, it had a bsod. So it is basically unusable. I took the PC to the computer guy and he said that the TX850 was incompatible with this motherboard.

All temps are good, no overclock, memtest86+ ran fine for 10 passes.

Any idea what is going on?

More about : tx850 psu compatible

January 27, 2012 11:08:20 AM

"I took the PC to the computer guy and he said that the TX850 was incompatible with this motherboard."
What is the mystery, exactly?
Another thing that makes the unit dump every 5 minutes is a bad driver that is incompatible with the hardware.
m
0
l
January 27, 2012 11:12:48 AM

shadow_city said:
I took the PC to the computer guy and he said that the TX850 was incompatible with this motherboard.


"The Computer Guy"

THAT is the mystery.

Ofc the PSU is compatible. Your computer guy is an idiot.

The 6790 sounds like its dead - RMA the GPU.
m
0
l
Related resources
January 27, 2012 11:37:02 AM

Computer Guy? It looks more like a Scammer Guy...
m
0
l
a b B Homebuilt system
January 27, 2012 11:56:41 AM

If there were a compatibility issue you would be able to read about it on the Corsair forums, I haven't read about one, could have missed it, don't know.

The first "psu incompatibility " that I came across was here
http://www.silentpcreview.com/article273-page5.html

They do exist, and there have been more over the years.
m
0
l
January 27, 2012 11:06:02 PM

Ok thanks for your replies and suggestions. I am just letting the "computer guy" figure it out since he is a good friend of my parents and will hopefully home in on the problem...
m
0
l
a c 122 B Homebuilt system
January 27, 2012 11:46:55 PM

shadow_city said:
1 week later I added a Powercolour HD 6790. Problems... White/grey stripes while gaming. Got a TX850 (thought I needed more power). Bad reading in HW monitor (2volts on 12v rail and I still got grey stripes while gaming).

HWMonitor gave you erroneous 12 volt reading. If you really had had 2 volt reading, your computer would never had started the POST, let alone booted to Windows.

Your "computer guy" - what does he really do for a living?
m
0
l
January 28, 2012 6:09:42 AM

jsc said:
HWMonitor gave you erroneous 12 volt reading. If you really had had 2 volt reading, your computer would never had started the POST, let alone booted to Windows.

Your "computer guy" - what does he really do for a living?


Fix,build computers etc. The usual stuff that computer repair shops do. I don't know about anything else...
m
0
l
January 28, 2012 1:27:39 PM

shadow_city said:
Fix,build computers etc. The usual stuff that computer repair shops do. I don't know about anything else...


Sounds to me like he does not have a scooby.
m
0
l
January 28, 2012 4:32:08 PM

WTH? Computer guy? The guy must be on another planet!

From my perspective, your GPU sounds like half dead. I would recommend you to RMA it.
m
0
l
January 28, 2012 9:06:22 PM

Ok I will tell him that.

Thanks for your replies
m
0
l
January 31, 2012 5:05:07 AM

laircouk said:
Gigabyte is a good brand. But, if I were you, I would have pick Asrock over Gigabyte. They use to be partnered with ASUS and their technologies performs better, last longer and provide easy update, such as Bios!

Anyway, it's your choice, your system... :) 

Asrock Z68 Extreme4
http://www.scan.co.uk/products/asrock-z68-extreme4-gen3...

Your chosen motherboard: GA-Z68X-UD3-B3
http://www.scan.co.uk/products/gigabyte-ga-z68x-ud3-b3-...


Thanks for suggestion. Looks nice except it was a bit expensive. So gigabyte it is.
m
0
l
February 1, 2012 10:47:22 AM

shadow_city said:
Thanks for suggestion. Looks nice except it was a bit expensive. So gigabyte it is.


No problem at all! Tom's hardware community is happy to help!! :) 

Gigabyte also doesnt use cheap capacitor, and, provide VERY GOOD passive ventilation!
m
0
l
February 3, 2012 6:28:38 AM

UPDATE: I am going to try and RMA the gpu as I am still having the same problems
m
0
l
February 3, 2012 2:08:39 PM

2nd reply

I quote myself

"RMA the GPU"

Listen to Toms, we are awesome.
m
0
l
February 3, 2012 10:06:00 PM

deadjon said:
2nd reply

I quote myself

"RMA the GPU"

Listen to Toms, we are awesome.


Yeah I should have listened...
m
0
l
!