Sign in with
Sign up | Sign in
Your question

NZXT tempest 410 problem

Last response: in Components
Share
May 10, 2012 7:20:05 PM

hi i have a NZXT tempest 410 case but one of the 2 front fans are not working even though they are connected to the fan connectors on the case?
is this due to a faulty case or have i done something wrong?
a c 104 ) Power supply
May 10, 2012 7:56:53 PM

Do you have the fancontroller plugged into a molex?
the fancontroller needs the power from the Psu to send to the fans,
if you are ok that way then it may be an issue with either the controller or the two fans, we can test the fans to rule that out
Moto
m
0
l
Related resources
January 13, 2013 12:23:13 PM

megadelayed said:
hi i have a NZXT tempest 410 case but one of the 2 front fans are not working even though they are connected to the fan connectors on the case?
is this due to a faulty case or have i done something wrong?



I am having the same problem where all the other 4 fans(2 top,on on the back and one of the two front fans work).I confirmed that the fan is not defective since i changed their positions to check as well as the fan's blue light is on but it is not rotating.I even tried directly connecting the fan to the power but still only the light is working but the fan's not rotating, its really strange for me.Could somebody help me to solve this?
m
0
l
January 13, 2013 2:14:05 PM

I had resolved it.That was a very silly mistake...:p  :p  I didn't fit the HDD cage properly so the hinges was blocking the fan blades not to move that's why it didn't work.I found it when i made a direct connection and removed its position and it started to work.
m
0
l
!