Sapphire Hd 5970 2gb Hemlock

Hello,
after i do the instalation of the card it wont enter to windows it will just freez in the logo when is loading, i could make it work but only with one of the cores working, i disable it on windows and now the card is working but only using one of the cores and that sucks . :(.

I need help to fix this problem.

NOTE: i have tryed diferent drivers, it did work fine until just a couple month a go, i have tried diferent OS giving me the same problem


motherboard M4A89GTD-PRO/USB3
ATI Radeon HD 5970 (Hemlock)
QuadCore AMD Phenom II X4 Black Edition 965, 3684 MHz (17 x 217)
Hard drive 465.7 GB
4 gb RAm
26 answers Last reply
More about sapphire 5970 hemlock
  1. What is the make/model of your PSU?

    What version of Windows are you using?
  2. my PSU is a spektra model ATX 800w

    WINDOWS 7 64 bits
  3. How many amps are on the +12/v rail(s)?
  4. 29 amps? On how many rails?
  5. features:

    - Nominal power: 800 Watts

    - 14cm Fan

    - Speed: 2000 rpm

    - Input voltage: 100V / 6A, 240V / 3A

    - Current output:
    * +3.3 V: 35A
    * +5 V: 35A
    * +12 V1: 29A
    * +12 V2: 29A
    *-12V: 0.8A
    * +5 Vsb: 3.0A

    - Output connection:
    * 1 x 20 +4 main connector pin
    * 1 x +12 V power connector 8-pin
    * 2 x floppy connector 4-pin
    * Connector 6 x 4-pin peripheral
    * 6 x SATA 5 pin connector
    * 1 x PCI-E 6-pin
    * 1 x PCI-E 8-pin
  6. I think your PSU might be the problem.The 5970 might be underpowerd.
  7. Really? With 29A per rail? Wouldn't that give nearly 60A total?
  8. No.When their are multiple rails you can't combine/treat the amps the same way as a single rail.Each rail has it's own power.The actual +12/v rail wattage is actually a lot less than 60 amps.
    Another thing to note is that this PSU is listed as being 800watts and even if it had a single rail with 60 amps that's still only 720 watts.I'm betting the actual wattage is somewhere in the 600 watt range which is still fine for a 5970 but you just can't trust these crappy PSU makers.

    You see how many amps this PSU would have if you combined all the rails?

    http://www.newegg.com/Product/Product.aspx?Item=N82E16817371051


    OP you should also make sure you've completely uninstalled the previous GPU drivers and reinstall the drivers for the 5970.
  9. im gonna try another psu and update my coments, thank you for yout time mate
  10. What other PSU do you have?
  11. i need to get one first. Can u tellme wish one on this website should i get, cause right now im living in chile so, chilean stores are my options. http://www.pcfactory.cl/?papa=326&categoria=54
  12. i noticed something im not sure what does it mean, i can only work with one of the cores, if i try to work only with the other one i have the same problem wish is freezing at windows start. Does it mean that meaby the problem is it not the psu ?
  13. As said before make sure you have the current drivers for the 5970(for your OS).And I believe you may need the ATI Catalyst Application Profile.

    When the Windows logo screen freeze's do you get a blue screen or it just hangs?

    Try booting into Safe Mode and see if you can use both GPU's.


    Now that I think about it this sounds more like a driver related issue than a PSU problem.But I still suggest upgrading your PSU to a more efficient and cleaner one.
  14. i have format and re install windows so many times deleted drivers. etc... now im trying to download driver sweeper.
  15. i cant find driver sweeper it seems that the download link is been down for a long time :(
  16. Ok i have try evrything rewarding to drivers and same problem over and over. is it possible the card is giving me problems?, is there such thing as 1 bad core¿?
  17. Yes it's possible.The PSU may also be the problem.
  18. It might be not important, but few days ago i got the same problem ( frezee at logo ) and i realized its because of ram ( i have 2x1 Kingston and 1x2 GOODRAM ). I needed to change ram into other slots. Maybe it will help.
  19. i tried moving the rams but it didnt work. im still using the one core is god. just left to try with another PSU but i dont have one :(
  20. Can you afford the one I posted earlier?
  21. Just curious,why did you O.C. with the FSB and not the multiplier? The 965 is a BE(unlocked multiplier) and it's such a small O.C. No sense in making things complicated if your only going for such a minor O.C.
  22. that oc was autmatic by the main board, i do not use oc.
  23. Maybe you should set it back to default.
    O.C.ing the FSB is messy and can cause problems if you don't know what your doing.
    Default FSB for the 965 is 200.
  24. im using default now and im having same problem :(
Ask a new question

Read More

Radeon Sapphire Graphics Product