Sign in with
Sign up | Sign in
Your question

Can't Transfer Large Files Over Network...HELP

Last response: in Networking
Share
February 16, 2011 5:12:44 PM

Router: Linksys WRT54GL
Main PC wired
HTPC Wireless
Win7

I am trying to transfer some blu-ray rips from the Main PC (wired) to the HTPC (wireless), but after 20-30 minutes it give me this error message and it can no longer locate the HTPC. i made sure the HTPC didn't so to "sleep" mode..

Something wrong with my home network or is it time to get a new router/adapter? everything else seems to work fine, except trying to transfer these huge files (10GB-20GB).



February 17, 2011 1:05:02 AM

anyone?
m
0
l
February 17, 2011 1:24:15 AM

have you tried connecting the HTPC via network cable and test if it works
m
0
l
Related resources
February 17, 2011 11:29:07 AM

trying opening up ping and doing ping -t htpc see if a connection issue occurring during the transfer?
m
0
l
February 17, 2011 12:13:01 PM

Kewlx25 said:
trying opening up ping and doing ping -t htpc see if a connection issue occurring during the transfer?


And if that is the case (I think Kewlx25 is on to something here), check for newer firmware for WRT54GL. I remember my old WRT54G router having similar problems when I first got it. Copying large files over both the wired LAN and wireless would actually result in my connection completely dropping to the router. Sometimes I could simply wait a few minutes and it would come back, but in most cases I had to actually reboot the unit.
m
0
l
February 17, 2011 12:32:43 PM

hey thanks guys, i know the network connection work as i have no trouble copying smaller files like pictures and documents.

but huge files transfer is giving me problem.

also, my transfer rate is around 650MB/s. and this is suppose to be a 54Mb router?
isn't this really SLOW?
m
0
l
February 17, 2011 12:36:08 PM

650MB/s isn't even possible on today's Gigabit routers. I think there was a typo there somewhere.... Are you sure you didn't mean 650KB/s? If so, then yes that is unusually slow. If that result is over the wireless, I would check the signal level at either end of the transfer and move the systems accordingly. If it's over wired, a simple reboot of the router might solve it.
m
0
l
February 17, 2011 3:12:44 PM

sorry, it was a typo...as you said 650KB...

signal strength is good 3/4 bars out of 5 most times.....

anything settings, etc. that can help to increase speed?
m
0
l
February 18, 2011 2:24:48 AM

First, make sure there is nothing artificially bottlenecking the connection. Check the router to make sure it's not capping the traffic speed at 10 Mbps, and also check to make sure your network adapters are set to auto-negotiate the connection speed instead of being hard coded to a certain speed. The drivers can be adjusted via the Advanced tab in the network adapters settings page in the Windows Device Manager. While you're at it, make sure your LAN drivers on every device are completely up to date with the manufacturer (do not check Windows Update, go to the motherboard manufacturer's website, or even better the NIC device manufacturer's website).
m
0
l
February 18, 2011 6:12:19 PM

well, i can download large files from the net at up to 20Mbps, so it doesn't seem the router is limiting it.

it's only transferring files from my main pc (wired) to the htpc (wireless) that's really slow. i guess i need to check on the htpc connection. suspect that's where the issue lies.

how would i go about testing the speed on the htpc (wireless)?
m
0
l
February 18, 2011 10:06:32 PM

ok, i moved my router from the floor to the cabinet top, about 4ft high and speed increased a bit. now i am transferring around 11-12Mbps.

still a far cry from the advertised 54Mbps.
m
0
l
February 18, 2011 11:38:15 PM

Where is the router in relation to the htpc? are they in separate rooms?
m
0
l
February 26, 2011 12:17:53 AM

wow...finally my transfer rate is around 21-22mbps...here's what i did.

1 - upgraded to latest linksys firmware
2 - move router from my entertainment center to the top of the cabinet
3 - changed channel to '11', it was at channel '6' before.

works great......
m
0
l
!