Sign in with
Sign up | Sign in
Your question

Bad 6970 ?

Last response: in Graphics & Displays
Share
November 29, 2011 2:47:06 AM

OK so I recently Built my own gaming rig , and some of the specs are HIS ICE Q 6970, i7-2600k,8gb ddr3 ram, and so on , But I recently downloaded fallout 3 and New vegas , Now when I was playing fallout 3 I noticed that objects didnt render well for example I would have to be really close to a bridge for it to render ( MY Settings On all games are 8aa 15Af 1080p Ultra settings) and or river borders to render , And when I installed some Fo3 mods Id get the AMD DISPLAY DRIVER CRASHED AND RECOVERED -But that really hasnt happened alot only twice , Ok so Now in new vegas , I have Un rendered Signs , Roads and Flickering Mountains , Like the textures on the mountains would flicker ( Ill put a video link Below) and when im outside in the game traveling the wasteland id get like 60 frames constant but then id go indoors And see like 6 npcs and my frames would drop to 30 frames to 40 frames And I know thats Below 6970 standards(For fallout at least) But yeah , I installed the lastest drivers(Re installed and checked on steam) Got the Latest CCC) so idk what the deal is , Like if I play crysis 1 demo id get 30-45 frames Which i still think might be too low for 6970 but like I said Im playing on 8aa 1080p and max settings on all games and max AF when a game has it , and Oblivion id get 60 frames constant , No flickering , but in a crowded area 50 frames , The main Question im asking here is #1 Is it my Gpu ? #2 what can be done about it if so. #3 Will I have to replace it , Well this forum might belong in games but I think its suitable here due to its most likely a gpu issue , anyway Thanks to the people who help me out and even read this :) 

http://www.youtube.com/watch?v=__lLvJrkEnI - SOmething like tht but with moutains(VIDEO BELONGS TO RAZIELCHAN666)

More about : bad 6970

November 29, 2011 10:07:51 AM

tony245 said:
OK so I recently Built my own gaming rig , and some of the specs are HIS ICE Q 6970, i7-2600k,8gb ddr3 ram, and so on , But I recently downloaded fallout 3 and New vegas , Now when I was playing fallout 3 I noticed that objects didnt render well for example I would have to be really close to a bridge for it to render ( MY Settings On all games are 8aa 15Af 1080p Ultra settings) and or river borders to render , And when I installed some Fo3 mods Id get the AMD DISPLAY DRIVER CRASHED AND RECOVERED -But that really hasnt happened alot only twice , Ok so Now in new vegas , I have Un rendered Signs , Roads and Flickering Mountains , Like the textures on the mountains would flicker ( Ill put a video link Below) and when im outside in the game traveling the wasteland id get like 60 frames constant but then id go indoors And see like 6 npcs and my frames would drop to 30 frames to 40 frames And I know thats Below 6970 standards(For fallout at least) But yeah , I installed the lastest drivers(Re installed and checked on steam) Got the Latest CCC) so idk what the deal is , Like if I play crysis 1 demo id get 30-45 frames Which i still think might be too low for 6970 but like I said Im playing on 8aa 1080p and max settings on all games and max AF when a game has it , and Oblivion id get 60 frames constant , No flickering , but in a crowded area 50 frames , The main Question im asking here is #1 Is it my Gpu ? #2 what can be done about it if so. #3 Will I have to replace it , Well this forum might belong in games but I think its suitable here due to its most likely a gpu issue , anyway Thanks to the people who help me out and even read this :) 

http://www.youtube.com/watch?v=__lLvJrkEnI - SOmething like tht but with moutains(VIDEO BELONGS TO RAZIELCHAN666)





Hi.

Ok so first i suggest boot into safe mode and uninstall the graphics driver completely, remove all ati software then reboot into windows as normal.
Download the latest driver from AMD. http://www.amd.com/us/products/desktop/graphics/amd-rad...

Save it to desktop. reboot back into safe mode and install the driver then boot back into windows as normal.

Then try the game again, without anti aliasing to see if that fixes the problem.

If not then try 3danalyzer to see if you can disable certain lighting effects to see if that will work. I have not used 3danalyze for a while so it may have alot more features now which may solve your problem. It is a free program, not even 25mb if i can remember correctly.

Also try a few different games if you have any to see if the problem occures in thoughs ones too. If so then it may be your GPU.

If you cant figure it out then it may be time to replace it. If you still have the receipt. And also download the latest directx
m
0
l
November 29, 2011 12:22:51 PM

First I think your card is ok. I would check to see that you case cooling is doing the job needed. These cards dump some of their heat into the case. You need to be able to exhaust it sufficiently. The driver failure message can be triggered by heat. Have you OC'd the video card? Also the coding done by modders is not always perfect. Game mods. are notorious for causing conflicts. Regarding the rendering or flickering at the edges, try the game with everything at medium or lower. If the effect is still there then you can figure it to be the way the card, drivers, system and game design interact. The frame rate drop you are seeing is pretty typical. AMD has a new driver out ver. 11.11a (http://support.amd.com/us/kbarticles/Pages/Catalyst1111...) with some game optimizations.
m
0
l
Related resources
November 29, 2011 5:43:47 PM

Ill try those suggestions and let you guys know how it turned out
m
0
l
November 29, 2011 5:44:11 PM

Oh I also Didnt OC anything
m
0
l
November 29, 2011 5:49:09 PM

Ok So Test 1 I lowered the game to medium settings AA off AF off and it still flickers Badly and I actually get worse frames then at ultra , OH I also Tried that gpu stress test The furmark one and my gpu Under super heavy stress gets to 70 C and no more and fallout and games in general arent that stress ful

m
0
l
November 29, 2011 5:59:24 PM

wonder44 said:
Hi.

Ok so first i suggest boot into safe mode and uninstall the graphics driver completely, remove all ati software then reboot into windows as normal.
Download the latest driver from AMD. http://www.amd.com/us/products/desktop/graphics/amd-rad...

Save it to desktop. reboot back into safe mode and install the driver then boot back into windows as normal.

Then try the game again, without anti aliasing to see if that fixes the problem.

If not then try 3danalyzer to see if you can disable certain lighting effects to see if that will work. I have not used 3danalyze for a while so it may have alot more features now which may solve your problem. It is a free program, not even 25mb if i can remember correctly.

Also try a few different games if you have any to see if the problem occures in thoughs ones too. If so then it may be your GPU.

If you cant figure it out then it may be time to replace it. If you still have the receipt. And also download the latest directx



COuld this be whats wrong - I have an nvidia chipset and display for mobo while ati display at the same time - IM using driver sweeper btw and also ageia PHYSX Btw the mobo is ASROCK p67 extreme gen 4, Yeah so im stuck on what to do...
m
0
l
November 29, 2011 7:06:09 PM

Ok I did everything you guy's suggested , re installed amd soft ware - lowered settings even removed all the mods , Im gonna try fallout 3 now and if i get graphical issues there too im just gonna send it back to get a replacement
m
0
l
November 29, 2011 7:18:11 PM

The problems you are listing are problems generally associated with faulty drivers. The card temps are stable and furmark runs fine, your card is not artifacting ......its a driver issue. When I switched my comp from a 5970 to 580's even after driver sweeper I still had problems. The only fix for me was a fresh install of windows =/. Might want to back up your data/HD and try that. Because from the sounds of it even if you send a card back you are going to experience the same problems.
m
0
l
November 30, 2011 12:35:00 AM

Did you install that GPU after windows was installed? or did you install windows while the card was already in your machine?
m
0
l
November 30, 2011 1:08:22 AM

wonder44 said:
Did you install that GPU after windows was installed? or did you install windows while the card was already in your machine?

I installed windows while the card was in the machine for the first time
m
0
l
November 30, 2011 1:09:28 AM

envymert said:
The problems you are listing are problems generally associated with faulty drivers. The card temps are stable and furmark runs fine, your card is not artifacting ......its a driver issue. When I switched my comp from a 5970 to 580's even after driver sweeper I still had problems. The only fix for me was a fresh install of windows =/. Might want to back up your data/HD and try that. Because from the sounds of it even if you send a card back you are going to experience the same problems.

How would I freshly install windows (honestly I could care less about the files that would be deleted because I only have like 3 games and some mods nothing else really)
m
0
l
November 30, 2011 1:14:09 AM

Oh i forgot to say , after i re installed all the drivers and stuff my screen started flashing and when i booted up windows the screen turned all red and started to become distorted .... I installed the gpu to another pci x 16 3.0 slot and now windows is booting but the games are still glitchy
m
0
l
December 1, 2011 3:00:54 AM

Yeah < I re-installed windows 7 and it still does that nothings working , IM just gonna send in my gpu i guess
m
0
l
!