Sign in with
Sign up | Sign in
Your question

Grey Screen Issue - New 6870 Graphics Card

Tags:
  • Graphics Cards
  • Power Supplies
  • Graphics
Last response: in Graphics & Displays
Share
November 30, 2011 4:34:23 PM

I have just installed a new PowerColor AMD HD 6870 graphics card on my system and the screen occasionally goes completely grey, it seems to be randomly triggered. It has also gone a light blue before when I tried to change to Aero mode in Windows 7.

Once this happens the system seems completely unresponsive and I have to do a hard restart.

At first I thought it could an inadequate power supply (my previous graphics card was 8800 GT which ran fine), however there doesn't seem to be any problems playing games and I have ran various CPU burn-in tools with no issue. The are no other unexplained issues, just the screen going completely one colour. My power supply is a Hiper Type M 530w.

I think the only other reason is the 6870 is faulty.

I have tried the latest AMD drivers.

Can anyone tell me which is the more likely of the two - inadequate power supply or faulty card?

Thanks.

My system specs are -

AMD Phenom II 925
4GB DDR3 RAM
500GB Seagate HD
MSI 760GM-P23 Motherboard
Hiper Type M 530w PSU

More about : grey screen issue 6870 graphics card

November 30, 2011 4:46:18 PM

I have just installed a new PowerColor AMD HD 6870 graphics card on my system and the screen occasionally goes completely grey, it seems to be randomly triggered. It has also gone a light blue before when I tried to change to Aero mode in Windows 7.

Once this happens the system seems completely unresponsive and I have to do a hard restart.

At first I thought it could an inadequate power supply (my previous graphics card was 8800 GT which ran fine), however there doesn't seem to be any problems playing games and I have ran various CPU burn-in tools with no issue. The are no other unexplained issues, just the screen going completely one colour. My power supply is a Hiper Type M 530w.

I think the only other reason is the 6870 is faulty.

I have tried the latest AMD drivers.

Can anyone tell me which is the more likely of the two - inadequate power supply or faulty card?

Thanks.

My system specs are -

AMD Phenom II 925
4GB DDR3 RAM
500GB Seagate HD
MSI 760GM-P23 Motherboard
Hiper Type M 530w PSU
a b U Graphics card
November 30, 2011 5:04:05 PM

try to adjust the cable of your moniter which connected to the video card remove the card and blow air into slot and put it back again carefullt.
Related resources
a c 153 U Graphics card
a b ) Power supply
November 30, 2011 5:05:37 PM

I would bet dollars to donuts its that PSU. If you have a friend with a good PSU laying around see if he will let you test it.

Good companies would be Antec, PC Power and Cooling, Silverstone, Corsair, XFX, some OCZ, and some Cooler Masters.

If it isn't a PSU issue it could be a driver issue since you just went from Nvidia to AMD. Use driver sweeper in safe mode to remove all Nvidia Display drivers and make sure to install the latest AMD driver afterwards.
a c 274 U Graphics card
a b ) Power supply
November 30, 2011 5:14:47 PM

This next topics has been merged by Mousemonkey
  • Grey Screen problem - New 6870 Graphics Card
    November 30, 2011 5:26:20 PM

    I have just installed a new PowerColor AMD HD 6870 graphics card on my system and the screen occasionally goes completely grey, it seems to be randomly triggered. It has also gone a light blue before when I tried to change to Aero mode in Windows 7.

    Once this happens the system seems completely unresponsive and I have to do a hard restart.

    At first I thought it could an inadequate power supply (my previous graphics card was 8800 GT which ran fine), however there doesn't seem to be any problems playing games and I have ran various CPU burn-in tools with no issue. The are no other unexplained issues, just the screen going completely one colour. My power supply is a Hiper Type M 530w.

    I think the only other reason is the 6870 is faulty.

    I have tried the latest AMD drivers.

    Can anyone tell me which is the more likely of the two - inadequate power supply or faulty card?

    Thanks.

    My system specs are -

    AMD Phenom II 925
    4GB DDR3 RAM
    500GB Seagate HD
    MSI 760GM-P23 Motherboard
    Hiper Type M 530w PSU
    a c 274 U Graphics card
    a b ) Power supply
    November 30, 2011 5:40:53 PM

    This next topics has been merged by Mousemonkey
  • Grey Screen Issue - New 6870 Graphics Card
    a b U Graphics card
    a b ) Power supply
    November 30, 2011 7:30:05 PM

    I had a Hyper M-530 PSU...It only had 30 amps on the 12V rails. I would also say it is a PSU issue.
    April 1, 2012 12:26:55 PM

    Hey, anybody fixed that grey screen issue?
    April 13, 2012 7:18:21 PM

    This is currently happening to me as well. I also have a 6870, from powercolor. I used to run a nvidia as well. I had a xion 700w but replaced it with a corsair hx850...same problems...i would like this porblem solved before i spent shipping money for an RMA
    April 15, 2012 7:51:00 PM

    I have found this card doing the same thing on another computer when playing movies (when switching mem CLK).. I have sent the card once again for RMA via my supplier.. This time I have recorded the issues when it happens. I hope they will replace this card... If not I will never buy the AMD/ATI again..
    !