Sign in with
Sign up | Sign in
Your question

System Not Recognizing Graphics Card

Last response: in Graphics & Displays
Share
December 1, 2011 8:31:51 PM

Hey guys,

So I just replaced a bunch of parts on my computer and have come to find that my old graphics card, which worked perfectly on my old computer, doesn't seem to be recognized by my new stuff. I'm trying to run a VisionTek HD 5670 on an ASRock Extreme3 Gen3 (Z68) board. I can get the Intel graphics just fine, but Catalyst nor Lucid Virtu wants to recognize my card. I've tried wiping any ATI drivers and re-installing them, but to no avail. I can't tell if it's a software issue, hardware incompatibility, or if my PCIe ports are just broken. Oh, also, the card is getting power (the fan is on), and when I switched PCIe ports the computer installed the PCIe controller drivers, but still no card. Any suggestions?
a c 502 U Graphics card
December 1, 2011 9:33:41 PM

With the discrete graphics card in slot PCIE2 and the monitor attached to the primary graphics port on the graphics card are you able to see the POST (Power On Self Test) screen? If not then you have a hardware problem.

What are your settings for ASRock UEFI Setup Utility --> Advanced Screen --> North Bridge Configuration?

Primary Graphics Adapter [Onboard] or [PCI] or [PCI Express]?

IGD Multi-Monitor [Enabled] or [Disabled]?
December 1, 2011 11:02:04 PM

ko888 said:
With the discrete graphics card in slot PCIE2 and the monitor attached to the primary graphics port on the graphics card are you able to see the POST (Power On Self Test) screen? If not then you have a hardware problem.

What are your settings for ASRock UEFI Setup Utility --> Advanced Screen --> North Bridge Configuration?

Primary Graphics Adapter [Onboard] or [PCI] or [PCI Express]?

IGD Multi-Monitor [Enabled] or [Disabled]?


Nothing shows up on the screen when I plug in the D-sub cable to the graphics card and turn it on. The primary graphics are on board (Z68 Sandy Bridge Intel stuff). I haven't checked the north bridge settings yet. I'll do that when I get back to my Desktop. Any ideas (if it us hardware) how I'd tell if it's a compatability or a motherboard issue?
Related resources
December 2, 2011 3:09:05 AM

go to bios settings and disable igd. also change primary graphic adaptor to pci express.
December 9, 2011 2:52:38 AM

Thanks guys. Looks like my PCIE port was defective. Sent the motherboard back to Newegg and the replacement is on its way. Hopefully this one works out.
!