Sign in with
Sign up | Sign in
Your question

Display Driver Crashing

Last response: in Graphics & Displays
Share
December 1, 2011 8:42:12 PM

Hello,

I've had a recurring problem since I bought my 6970 about 6 months ago. I have removed the stock cooling fan, and I am running a water block on this particular card. It is made by XFX. The problem is that when I play any 3D game, It crashes and I get the "Display driver has crashed and has been restored" message. If I run a lower end game for a while to pre-heat the card, I never crash. It runs perfect. I only does this when the temperature is between 30-34 degrees, and it never does it with the stock fan, only when the water block is attached.

If I had to guess, I'd say the firmware doesn't like running while the GPU is too cold. I've talked to XFX and they claim no knowledge. I have turned my water pump to it's lowest setting, but even that doesn't help the initial crashing issues.

Does anyone have any knowledge of this issue or how to fix it?

P.S. I run a 3 monitor Eyefinity setup.
December 1, 2011 9:00:36 PM

"... and it never does it with the stock fan, only when the water block is attached."

Maybe something to do with having to detect fan speed in relation to GPU temperature.

If the fan is left attached while the water block is also attached and in operation does this problem still happen? If the problem doesn't happen you've found the cause.
December 1, 2011 9:19:33 PM

jatznic said:
Hello,

I've had a recurring problem since I bought my 6970 about 6 months ago. I have removed the stock cooling fan, and I am running a water block on this particular card. It is made by XFX. The problem is that when I play any 3D game, It crashes and I get the "Display driver has crashed and has been restored" message. If I run a lower end game for a while to pre-heat the card, I never crash. It runs perfect. I only does this when the temperature is between 30-34 degrees, and it never does it with the stock fan, only when the water block is attached.

If I had to guess, I'd say the firmware doesn't like running while the GPU is too cold. I've talked to XFX and they claim no knowledge. I have turned my water pump to it's lowest setting, but even that doesn't help the initial crashing issues.

Does anyone have any knowledge of this issue or how to fix it?

P.S. I run a 3 monitor Eyefinity setup.



Try going into CCC and setting fan control to Manual and set at 100%. That might do the trick.
Related resources
December 1, 2011 9:26:50 PM

jatznic said:
Hello,

I've had a recurring problem since I bought my 6970 about 6 months ago. I have removed the stock cooling fan, and I am running a water block on this particular card. It is made by XFX. The problem is that when I play any 3D game, It crashes and I get the "Display driver has crashed and has been restored" message. If I run a lower end game for a while to pre-heat the card, I never crash. It runs perfect. I only does this when the temperature is between 30-34 degrees, and it never does it with the stock fan, only when the water block is attached.

If I had to guess, I'd say the firmware doesn't like running while the GPU is too cold. I've talked to XFX and they claim no knowledge. I have turned my water pump to it's lowest setting, but even that doesn't help the initial crashing issues.

Does anyone have any knowledge of this issue or how to fix it?

P.S. I run a 3 monitor Eyefinity setup.

December 9, 2011 12:33:03 AM

Good idea, but same results. Complete lockup, followed by a recovery of the graphics, then it tries again. It will just loop this until eventually the card gets warm enough to run without crashing.
!