Solved

Not Allowed To Edit My Own Message?

I don't seem to be able to edit my own posts other than using the quick edit functionality.

I can click on the edit button and the edit form appears however when I press select I get presented with a page stating "You are not allowed to edit this message!"
16 answers Last reply Best Answer
More about allowed edit message
  1. Best answer
    You can only use the quick edit function.Only mods can use the normal "edit"
    It's locked to other users because there are some options which only mods can change(such as make it a sticky topic etc.)
  2. Somewhat confusing but thanks!
  3. Best answer selected by Rusting In Peace.
  4. Maziar said:
    You can only use the quick edit function.Only mods can use the normal "edit"
    It's locked to other users because there are some options which only mods can change(such as make it a sticky topic etc.)

    Actually normal users should be able to use full edit, since the mod-only options won't show up for them anyway. The problem is that it sometimes just doesn't work, and this is most common on the UK forum.
  5. Before i become a mod,I tried using the full edit.My message showed up but when I clicked on "Save changes", it got the same error as OP.
    And I were in the US forums
  6. I just tried this with my other user account (non-mod), and I was able to use the full edit function.
  7. Yep, my full edit seems to work too.
  8. Strange,maybe something has changed then. Because when I weren't a mod, I couldn't at all use the "full edit" function.
    @ OP
    In which forums do you have this issue ? UK or US ?
  9. It's via the UK forums.
  10. Switch to US forums then and see if it helps.

  11. Makes no diifference here, I'm afraid. The ongoing problems with UK posters Badges failing to show is also the same when looking only at the US Forum. A couple of weeks back, I posted for three days from a Central European IP address and that made no difference either.
  12. Indeed Saga lout.

    I don't think it's possible to access all threads via .com. Hitting pages seems to redirect to .co.uk and setting the url to .com after doesn't always work (ever? I've not tested this sufficiently). The user is presented with a message stating the thread could not be found.
  13. PM me and I will show you how to avoid that redirection

  14. I edited my Hosts file to prevent it but the Badges problem remains the same. It must only affect posters with UK based IP addresses. It's no geat issue - especially if the upgrade fixes it in due course.
  15. Editing your host file will keep you from being redirected in the future. However, there are separate badge totals on each side. Simply stopping the redirect from side to side, won't merge your badge (and/or best answer) total. Instead, your future best answer, and badges, will accumulate on the US side.
  16. Yep, that's how it is :) Just stick to the US site and enjoy a slightly less buggy experience :lol:
Ask a new question

Read More

Site Bug Reports Tom's Hardware