Sign in with
Sign up | Sign in
Your question

laptop sound??

Last response: in Linux/Free BSD
Share
December 19, 2001 4:46:50 AM

Hi guys,
I was lookin for help with my installation of RH 7.2 on my laptop. I have compaq presario 1925 and i just recently installed the os. I have tried to figure out the sound problem but with no avail. If anyone can help me out with it. I would be very happy.

The problem is i dont get any sound!! As basic as that sounds, wen i login, and go under hardware browser it shows that SOUND DEVICE: MagicMedia 256AV Audio and under UNKNOWN DEVICES: -NeoMagic MagicWave 3D Sound System:unkown

When i play cd's it runs (the timer and stuff), but no sound comes out, i tried going into the sound server settings and mess around, and wen it trys to restart the server it gives an error :
"Error while initializing the sound driver:
device /dev/dsp can't be opend (no such device)

The sound server will continue, using the null output device"

How do i change this ?? Cuz i belive it does detect that i have sound card.. cuz it says that its neomagic etc etc under hardware browser ---

If you guys have any ideas of what i am suppsod to do. Please send me a message. Thank you.

AP


I'm not young enough to know everything.
- J.M.Barrie

More about : laptop sound

Anonymous
a b D Laptop
December 29, 2001 8:34:16 AM

hey.

it detects the sound card alright, but it isn't loading any drivers for it.

I don't know a lot about rh7.2, but it looks like <A HREF="http://www.alsa-project.org" target="_new">alsa</A> supports your chip. Install the alsa drivers, libs and utils, and you should be able to get it going. rh probably has rpms you can install.

7.1 sometimes needed you to run 'setup', and configure sound post-install, but i dunno about 7.2. The ALSA drivers are probably a good idea anyway.
Related resources
!