Sign in with
Sign up | Sign in
Your question

Netflix and Screen Tearing

Tags:
  • Radeon
  • Netflix
  • Graphics
Last response: in Graphics & Displays
Share
December 7, 2011 2:00:30 AM

When watching Netflix via the HTPC in full screen I seem to be getting quite a bit of screen tearing - especially on pans. Is anyone else aware of this issue and knows of any solutions?

I'm hooked up to a brand new Vizio with built in Netflix which we have watched for a few hours already and it seems fine (i.e. no tearing using built in app).

As I will be installing XBMC (or alternative) as my next step - I would prefer to be able to manage all media from the HTPC and never use the Vizio's apps. Honestly I build this PC to watch streaming media, Netflix being one of the major ones. I know dozens if not hundreds of people on this board ask for advice and build HTPCs to use among other things, Netflix - and many of those are recommended to llano- based builds.

I'm using the on-board llano graphics (A8-3850), set at 1920x1080 and the TV is a 1080.
It appears the highest refresh rate the llano does is 60Hz. The TV is a 120Hz TV and does have settings to remove the picture smoothing features, but can't actually be toggled to 60Hz mode...I'm not sure if this has anything to do with it, but I hope not. I don't really have another TV to test with. I can hook it up to my smaller monitor, but it won't be HDMI (VGA only).

There seem to be older issues with this with NVIDIA cards, especially on Macs, which a Firefox setting resolved. I've tweaked around in CCC with some settings, but nothing seems to help.

Any advice?

More about : netflix screen tearing

December 7, 2011 3:17:18 AM

So doing more research it seemed this is a pretty widespread issue for many users on many systems. The fingers seemed to point mostly at the Silverlight implementation of Netflix that is used on PC/Mac. Some blame Silverlight, some blame the way Netflix may have been encoding the stream to Silverlight-based players (namely everything that's not a STB).

I discovered that there is a Silverlight 5 RC that was supposedly to be RTW last month, but it's on delay right now. You can however download it here (go to bottom of page).

I installed it, checked my version at http://www.silverlightversion.com to ensure I was on 5.x, and then tried Netflix.

The tearing issues appear to be completely gone after watching about 10 minutes where I was definitely seeing it before!

If anyone else is having the issues, please update and let me know if things got better for you too!
m
0
l
February 7, 2013 11:42:08 PM

I have a C2D 3.0GHz, 4GB DDR3, G41 chipset.
Under Windows XP, I got tearing on the NVIDIA GT610, and RADEON HD4350 when HDMI was hooked up. Spent a day reading forums and trying all sorts of settings including Inspector tweaks. Improved the quality, but the tearing remained. Spent lots of time toying with resolutions too.
Loaded Winows 7 Home Premium and again tried both cards. Same dang thing. Aero being on or off made no difference.
Got mad, unplugged HDMI and removed ATI card. Plugged a standard VGA cable into the onboard socket. Booted to Windows 7 and played Netflix. WOOHOO!!!! NO TEARING AT ALL. But I did notice a hint of frame stuttering. Nothing huge, but if you are looking for it you'll certainly find it.
Neither the ATI Radeon 4350 nor the GT610 exhibited page tearing when the standard VGA connector was hooked up. GT610 had least frame stutter on youtube videos, and you really got look hard to find anything wrong.
But most importantly, NO MORE TEARING.
YouTube also has no more tearing.

The only thing I can think of is vertical synchronization (vsync) is not always being recognized by some TVs or some video cards, or drivers.

If you spend more than 20 hours barking up the wrong tree, put the VGA cable in and call it a day.

Yeah, the HDMI is more crisp on static images, but the analog looks pretty dang good when watching motion video. So, are you reading on your living room TV or watching motion. Those are the things to ask yourself.

So far I have to re-install Windows XP and try this again. Will let you know. Or you can search for 'rooftop235' and I am halfway down the page. Contact me and let's talk. This is fun.

This has been a subject I have spent a lot of time and money on over the past couple years.
m
0
l
March 28, 2014 6:22:20 PM

GO TO RUN, TYPE IN SERVICES
GO TO Desktop Window Manager Session Manager RIGHT CLICK ON IT AND THEN PROPERTIES, THEN AUTOMATIC, THEN START SERVICE, THEN APPLY
SAME THING IS WITH Theme SERVICE, AND THAT'S ALL
m
0
l
!