Sign in with
Sign up | Sign in
Your question

Graphics card artifacting? Error in Drivers? Plz help

Last response: in Graphics & Displays
Share
December 7, 2011 10:32:39 PM

Hello,
I just built my new rig about two weeks ago and it was playing games just fine (i.e Skyrim, Mass Effect 2 and whatnot). Then these black squares started flashing all over my screen during games. The weirder part is that it doesn't happen during loading screens just live game play. I actually bought DriverBoost to detect and install all out of date drivers. Still buggy, updated DX11 still having issues. I'm not having any overheating issues ( idle around 31C gaming about 55C) nor am i overclocking anything. This is becoming very bothersome. I will try to attach screen caps of the issue. The only thing i can think of is either my card is going out OR that this particular driver ATI I/O Communications Processor SMbus Controller is out of date according to my Driverboost although it just will not update. Please any feedback would be greatly appreciated.


System Specs:
AMD Phenom II 1090T X6
ASUS M5A99X MB
ATI Radeon Sapphire 4870 HD (bought used)
Corsair 850W Power Supply
8G Kingston DDR3 Ram
Windows 64bit OS

Screen Caps:
ScreenShot2.jpg picture by seriphim1 - Photobucket



ScreenShot4.jpg picture by seriphim1 - Photobucket
December 7, 2011 10:40:26 PM

Have you overclocked your graphics card?
m
0
l
December 7, 2011 10:57:05 PM

no i sated previously that i am not overclocking anything at all.
m
0
l
Related resources
a b U Graphics card
December 7, 2011 11:13:40 PM

Seriphim1 said:
this particular driver ATI I/O Communications Processor SMbus Controller is out of date according to my Driverboost although it just will not update.

Are you attempting to do the updates with the driver file, or are you just letting this program fail at doing it itself? Download the latest driver directly, and then the previous one if it still doesn't work. If that fails, clock down some.
Your photo links are not links.
m
0
l
May 16, 2012 10:50:31 AM

Seriphim1.
Have you resolved the issue?????
If so, what did you do???
m
0
l
!