Sign in with
Sign up | Sign in
Your question

Sapphire 5870 dead?

Last response: in Graphics & Displays
Share
December 9, 2011 8:27:43 PM

SPECS:
Asus M4A89GTD-PRO\USB3
AMD Phenom II x2 555 3.2GHz@ x4 B55 4.3GHz
Scythe Mugen 2 Rev B. /w Push-pull Scythe "Slipstream" 1200 RPM DC FAN
seasonic 620w s12ii-620 bronze PSU
Samsung "Spinpoint" F3 108J 1T HDD
2GB x2 (4GB total) Corsair CM4GX3M2A1600C9 (in other words, 2 overclocked-at-arrival memory kits of 1600\9-9-9-24 that their SPD is 1333 9-9-9-24)
and the video card
Sapphire (non refference) 5870 HD 1GB

I recently bought the CPU-cooler (does awesomely, before that the temps I would reach with AMD for this frequency + 2 opened cores would be about 40C, now I am about 30C, 15-20C idle full fan setup), new memory kits (old one had too loosen timings for stability, with this new one I can overclock timings much easily by reducing the frequency, even though it's not on the SPD's profiles) and an aftermarket VGA cooler (Accelro Twin Turbo PRO, even though this card doesn't have any programmable voltage regulators, or at least easy to program voltage regulator as no software, even ATTRIX, can change it's voltage, so overclocking-too-much this VGA is hard without a good BIOS modifiting) after installing the aftermarket VGA cooler to the VGA and inserting it to the PC, it simply would not send any informotion to any of the monitors (I am using multiple-monitoring display), I tried using a differnet PCI slot, didn't work, I tried a different card (Twintech 96 GT), it worked, so I booted the iGPU (on-board GPU, using shared memory) and tried to see the card on GPU-Z, I saw the card but the clock speeds were incorrect, the tempertures reading was incorrect, half of the info GPU-z was either grayed-out or incorrect, I tried downloading the BIOS and GPU-z couldn't find any BIOS (which leads me to think the card shorted out?), I tried flashing a different BIOS, I think that I managed one time to successfully flash a BIOS because then GPU-Z would show a very accurate informotion, after a reboot the problem resumed, I didn't forget to connect the aftermarket VGA cooler to the PCB, I ensured the fans are working, I also see some weird shared memory requirement from the iGPU, each boot it requires different amount of memory, sometimes it's 1.5GB, sometimes it's 1GB and sometimes it's 0.5GB, though on BIOS I set it to 0.5GB, when I use Windows's memory diagnostic of use, I see that sometimes more then 0.5GB is used for "hardware & bios" [shared memory], I wonder where it goes if not for the iGPU?

More about : sapphire 5870 dead

December 9, 2011 8:40:08 PM

Its probably been battered with OC and you not relized it. The 5xxx + OC = Bad heat.
The memory is the virtual memory that does support the card. The cards have virtual memory that is more then 1Gb because it is well.. Virtual! For it being a 'Sapphire' and a 5xxx series I wouldn't be surprised if it is not well like you said. "dead"

My opinion, after reading some stuff on google. Card got to hot; internal parts went out, or a short. Since you can't crossfire you won't be able to tell that easily. You are getting readings of some type on iGPU though? Unless I read wrong. I would suggest investing in a new video card. If you have the money wait for the 7xxx series, and get a 67xx series as a back up for the mean time. Hope this helped.

Also if you have another PCI-e slot plug it in and see the results if any? Also have your case open and with an anti static sheet on, after you have had the computer on doing something more then just sitting there, feel the Graphics card and see if it is hott. Even if you are using the MB gpu it will still draw power if it is not shorted out.
m
0
l
December 10, 2011 10:55:56 AM

I don't have so much cash so 7xxx series is out of the question as their prolly over priced, the 5870 purchase was hardly possible, also it couldn't have been battered with OC as I never overclocked this video card, I just noticed a bad use of drivers on certein games (overheat) and wanted to change the cooler for this very reason, the overheat happened with the original ATI drivers and Sappphire's bios's and the default clock speeds, I tried a different PCI-e slot and there wasn't any positive results, it doesn't suprise me as the 9600 GT is using the same slot, I can't really talk to the card even though it's inserted since it doesn't run any BIOS, so I can't directly stress or make the card run anything, it just requires its wattage and the tempertures are kept down by the aftermarket cooler which does a fantastic job (29C according to the only time I managed to write the BIOS and the card "lived" until the restart), the card lived for a boot there, meaning it still got juice, I just don't know how I did it or why it happened in first place, and I placed the heatsinks correctly, it's not my first time changing a VGA cooler, I contacted Sapphire for support ticket/warranty
m
0
l
!