Solved

Driver dilemma

Onboard sound died, I remembered a box with a cheapo sound card in it, even had a driver disk. But could I get it to install.... No name on the card, but it has a ct5880 chipset, which I believe is a Creative card. There are lots of folders on the disk, I've tried running the setup files to no avail, but I'm not sure which is the correct one anyway.

Peraps someone can link a creative card to one of the folders...

http://prntscr.com/9q4kq

I've tried updating the driver in Device Manager, but Windows can't find it online. The Onboard Sound has been disabled.

http://prntscr.com/9q529

Stuck...
3 answers Last reply Best Answer
More about driver dilemma
  1. Best answer
    You forgot to tell us your windows version, that's probably why you've had no replies. We can't help you without that info so many people probably just ignored your post.

    If it's a very old soundcard and you're trying to install it on a new or recent version of Windows, it's quite possible that none of the drivers are compatible if the card was manufactured way before Windows Vista or Windows 7 was launched.

    I just did some checking around and it seems the Creative CT5880 dates right back to 2001 at least, so no chance it will have any drivers for Windows 7, and possibly not even for Windows Vista which didn't appear as RTM until late 2006.
  2. phil22 said:
    You forgot to tell us your windows version, that's probably why you've had no replies. We can't help you without that info so many people probably just ignored your post.

    If it's a very old soundcard and you're trying to install it on a new or recent version of Windows, it's quite possible that none of the drivers are compatible if the card was manufactured way before Windows Vista or Windows 7 was launched.

    I just did some checking around and it seems the Creative CT5880 dates right back to 2001 at least, so no chance it will have any drivers for Windows 7, and possibly not even for Windows Vista which didn't appear as RTM until late 2006.

    Thanks, came to that conclusion myself. Got it off Ebay last year and never used it. Didn't realise it was that old!Concede point viz Operating System, thought i'd included it in my configuration but hadn't. Anyway, you deserve 40 points for your answer, at least confirms my suspicions! Got a nice card off Ebay, Audigy 2 ZS and it installed just fine.
  3. Best answer selected by dodger46.
Ask a new question

Read More

Sound Cards Creative Components