Sign in with
Sign up | Sign in
Your question

New PSU seems to not power SATA/ IDE (OCZ550FTY)

Last response: in Components
Share
May 27, 2012 10:09:11 PM

Hi,
I needed to replace my power supply in my 4 year old custom PC which worked fine until recently, now I bought a PSU OCZ550FTY to replace it.

My system spec:

AMD Athlon Dualcore 2200
Motherboard: M2N32-SLI Deluxe
Graphic Card -works fine, it's a Club 3D M2N32-SLI
2GB memory

Peripherals: I got 1 SATA hard drive, 1 SATA DVD drive, 1 old IDE hard drive.

Now when I installed the PSU, the system wouldn't want to boot up and I tracked it down to the peripherals connectors- when I unplugged all peripherals, it did boot.
I tried around a little bit with different combinations and it's now booting with all peripherals connected - but it won't recognize any of the drives in the Bios. I also can't open the DVD tray so there is a definite indicator that the drives are not powered for whatever reason.
There is definitely power on the 5V rails though - as the chassi fans are connected to that as well and they start up


The hardware monitor in the bios says it only delivers 4.86V on the 5V channel - not sure if this difference can cause these problems..

what can be the problem? Is the power supply not compatible with my 4 year old system?
a b ) Power supply
May 28, 2012 2:20:10 AM

Sounds like you bought a defective PSU, OCZ is not a bad power supply but every once in awhile a bad one crops up, just rma it and try the same model or try one from corsair or seasonic. Look at one with a single 12v. rail that way you don't have to worry about balancing the 12v. lines.
m
0
l
June 3, 2012 3:47:30 PM

hmm unfortunately it looks like a motherboard / controller problem!
I got another power supply and same issue.. no power on IDE and SATA drives.. I guess I have to get a new motherboard therefore?
Wanted to avoid that..
m
0
l
Related resources
!