Sign in with
Sign up | Sign in
Your question
Closed

AMD FX 4100 Only displaying 2 cores all of a sudden.

Tags:
Last response: in CPUs
Share
May 31, 2012 1:04:00 AM

Went to check the temps on my AMD FX 4100 O.C. 4ghz and noticed it was only displaying two cores. I proceeded to check every source I could think of, task manager, CPU-Z, HW Monitor, msconfig -> advanced -> boot only has the option to select 2 cores. I checked my Bios and it has all four cores enabled. It has always shown four cores before. I did update my bios recently, not sure if this is connected. I am about to re-install windows, but in case that doesn't work I would really appreciate any help with this incredibly troubling matter.

Thank you.

Motherboard: GIGABYTE GA-970A-D3
CPU: AMD FX 4100 O.C. 4.0ghz
Ram: 4x KINGSTON HYPER-X 4 GB DDR3/ 1600 MHZ
Video card: 2x AMD RADEON HD6850 1GB DDR5 PCIE
Boot Drive: 60 GB OCZ AGILITY 3 SATA III SSD
Hard Drive 2: 1TB Seagate Barracuda 7200rpm SATA3
Cooler: ASETEK 510LC 120MM WATERCOOLER
Powersuply: XTREMEGEAR 700 WATT POWER SUPPLY
a c 146 à CPUs
a b À AMD
May 31, 2012 1:29:39 AM

JAnkeny said:
Went to check the temps on my AMD FX 4100 O.C. 4ghz and noticed it was only displaying two cores. I proceeded to check every source I could think of, task manager, CPU-Z, HW Monitor, msconfig -> advanced -> boot only has the option to select 2 cores. I checked my Bios and it has all four cores enabled. It has always shown four cores before. I did update my bios recently, not sure if this is connected. I am about to re-install windows, but in case that doesn't work I would really appreciate any help with this incredibly troubling matter.

Thank you.

Motherboard: GIGABYTE GA-970A-D3
CPU: AMD FX 4100 O.C. 4.0ghz
Ram: 4x KINGSTON HYPER-X 4 GB DDR3/ 1600 MHZ
Video card: 2x AMD RADEON HD6850 1GB DDR5 PCIE
Boot Drive: 60 GB OCZ AGILITY 3 SATA III SSD
Hard Drive 2: 1TB Seagate Barracuda 7200rpm SATA3
Cooler: ASETEK 510LC 120MM WATERCOOLER
Powersuply: XTREMEGEAR 700 WATT POWER SUPPLY


It's showing as a dual core in CPU-z because it is a dual core CPU. Guessing you fell for AMD's true quad core, hexa-core. octacore scam. It's a dual core with two modules. Like the I3 is dual core with hyperthreading appearing as a quad core in task manager.
Score
0
a c 93 à CPUs
May 31, 2012 1:34:38 AM

Try unchecking the Processors checkbox in msconfig, that should make Windows default to the number of cores that BIOS sees.

If that doesn't work, it sounds like this could be a problem with the new BIOS. You may want to roll back to the previous BIOS version you had and see if that fixes the issue. If this is a BIOS problem, reinstalling Windows won't help you.
Score
0
Related resources
May 31, 2012 1:34:45 AM

But prior to this every program I listed showed 4 cores whether or not they were truly there (prime 95 for instance used to test four cores and now only tests two) and I have noticed significant stress on the cpu lately. Is this the result of a bios update and my computer is just no longer falling for AMD's tricks? Or do I have something to be worried about, such as dead cores?
Score
0
a c 146 à CPUs
a b À AMD
May 31, 2012 1:36:19 AM

Supernova1138 said:
Try unchecking the Processors checkbox in msconfig, that should make Windows default to the number of cores that BIOS sees.

If that doesn't work, it sounds like this could be a problem with the new BIOS. You may want to roll back to the previous BIOS version you had and see if that fixes the issue. If this is a BIOS problem, reinstalling Windows won't help you.


It sounded like he already did that. He said he checked the Bios and made sure all the cores were unlocked.
Score
0
a c 93 à CPUs
May 31, 2012 1:37:49 AM

You should see four physical cores. The Bulldozer modules have two cores that share FPU resources, but are otherwise independent, so it isn't quite like hyperthreading where the extra cores seen in task manager are entirely virtual. As I said above, you may have to roll back to an earlier BIOS revision, it could be that the newer version screwed something up with CPU core detection.
Score
0
May 31, 2012 1:39:43 AM

Will report back after bios rollback
Score
0
a c 99 à CPUs
May 31, 2012 5:48:15 AM

Windows task manager shows threads, not cores. It doesn't care what hardware the CPU has handling the threads, it just shows the number of threads.

Supernova1138 said:
You should see four physical cores. The Bulldozer modules have two cores that share FPU resources, but are otherwise independent, so it isn't quite like hyperthreading where the extra cores seen in task manager are entirely virtual. As I said above, you may have to roll back to an earlier BIOS revision, it could be that the newer version screwed something up with CPU core detection.


It sounds like somehow a module or the second set of integer pipes in each module got disabled. You can do both/either in the Bulldozer BIOSes I have seen. There is usually a menu to control number of cores. There would be a number of cores that goes down by 2- e.g. 8, 6, 4, 2- that shuts off entire modules. There is also an option called "Compute Unit" that turns off CMT and disables the second integer pipeline in each module. It would be easy to tell which it was doing if you had a chip with an odd number of modules like an FX-61xx as turning off entire modules would leave you with an even number of threads visible, and turning off CMT would leave you with an odd number of threads. Regardless, it's either a BIOS bug or a BIOS setting that was improperly set.
Score
0

Best solution

a b à CPUs
May 31, 2012 9:26:49 AM

JAnkeny said:
Will report back after bios rollback

shouldn't need to rollback the bios. there is a glitch sometimes with updating the gigabyte bios recently.

a co-worker built an 8120 on that board, worked fine, updated the bios, 4 cores only.. everything looked right but it wasn't.

in the bios, select "load failsafe defaults" and reboot. When I told him to do that, everything showed up and ran fine.

you will then have to re-configure your overclock.
Share
November 6, 2012 3:38:21 AM

noob2222 said:
shouldn't need to rollback the bios. there is a glitch sometimes with updating the gigabyte bios recently.

a co-worker built an 8120 on that board, worked fine, updated the bios, 4 cores only.. everything looked right but it wasn't.

in the bios, select "load failsafe defaults" and reboot. When I told him to do that, everything showed up and ran fine.

you will then have to re-configure your overclock.


I actually just noticed I was having the exact same issue and came across this thread while looking for a solution. Come to see I have the same mobo and cpu, and this actually fixed it right up for me, Hitting that "load fail safe defaults" in the bios.

Figured I needed to make an account just to say thank you. :sol:  :bounce: 
Score
0
November 16, 2012 1:09:06 AM

Best answer selected by JAnkeny.
Score
0
December 7, 2012 9:19:20 AM

Even i have the same prob..Could some one help..

my spec ..

AMD fx 6100
RAM 16GB 1033Mz
MB : ASUS M5A88-M

I am trying to install win xp 64 and i able to see only 2 cores in task manager.

I followed all the steps..(boot option as well in the bios) -didn't help.

I could use some help..
Score
0
!