Sign in with
Sign up | Sign in
Your question

New Build Help (Problems with Storage Devices)

Last response: in Systems
Share
February 13, 2012 10:09:25 PM

Hey everyone,
Im new to Toms Tips and in October built my first computer for gaming.
Specs:
Intel i5 2500k
Gigabyte GA-Z68X-UD3H-B3 Motherboard
Corsair TX750 V2 750W ATX 12V Single Rail 60A 24PIN ATX Power Supply Active PFC 80PLUS Bronze
Corsair CMV4GX3M2A1333C9 4GB DDR3 2X2GB DDR3-1333 CL9 Dual Channel Memory Kit
Coolermaster Hyper 212 Plus Direct Touch 4 Heatpipe Heatsink AM2 AM3 LGA1366 LGA1155 LGA1156 120MM
MSI N570GTX Twin Frozr II OC GeForce GTX 570 Fermi GFX Card
Lian Li A05N (the latest revision with USB 3.0)
Sandisk 120GB SSD
Microsoft Windows 7 Home Premium Edition 64BIT SP1
It worked great until 2 weeks ago when it randomly froze on me and wouldnt boot into Windows. I tried to reinstall Windows but for some reason the drive was not recognized or found. I tried to boot normally and it would just try to check the disk for errors but the check would never start. I ordered a Hard Drive http://www.directcanada.com/products/?sku=14120DR8182&v... to tie me over until I could get an RMA for the SSD and some mounting bays and a fan. http://www.newegg.ca/Product/Product.aspx?Item=N82E1681... http://www.newegg.ca/Product/Product.aspx?Item=N82E1681... http://www.newegg.ca/Product/Product.aspx?Item=N82E1683...
I installed all of them into my computer and disconnected the SSD. I was going to try to install windows on the drive but the same thing that happened with the SSD occured. I then too my computer apart once again and this time hooked up the SSD and HDD to the topmost SATA ports (on this picture the one in line with the top PCI slot http://www.gigabyte.com/fileupload/LineImage/2/3853/485... ) This time the same thing happened. However this time I booted from the DVD drive and went to install windows. Wonder of all wonders my SSD was recognized. However I didnt install as I saw all my files were on it. I restarted only to be brought back to square 1. All the same symptoms as before. I messed around some more with the repair options my BIOS gives me and after turning on the HDD was able to recognize it, however I could not install Windows onto it because of a formatting issue or something, I forget exactly.
Right now I am at the end of my unfortunately limited wits as what I should do. Any advice for troubleshooting or possible fixes is gladly welcomed. I do have my files backed up so its no big loss if I have to reformat the SSD.
THanks for your time
VR
February 13, 2012 10:32:52 PM

Sounds like Windows isn't recognizing the firmware on your drive. Try updating that from Sandisk's website (you'll need a USB storage device or blank CD) and see what happens.
m
0
l
February 13, 2012 10:33:47 PM

Did you check to see if there is an update on the SSD? Several companies have released updates to fix problems.
m
0
l
Related resources
February 13, 2012 10:42:15 PM

Okay I do have a USB drive. So what do I do? Download the firmware onto the USB drive and then plug it in and try booting? THanks for the help
m
0
l
February 13, 2012 11:39:57 PM

"We do not have any firmware available for the Ultra SSD drive and neither we have any further notifications about the same.”
I just got that message from Sandisk support. I guess Im screwed then?
m
0
l
February 14, 2012 1:07:55 AM

VanwaRaumo said:
"We do not have any firmware available for the Ultra SSD drive and neither we have any further notifications about the same.”
I just got that message from Sandisk support. I guess Im screwed then?


I'd call Sandisk to clarify but lack of updates would not be a good business practice, I think.
m
0
l
February 14, 2012 3:15:21 AM

Well I booted from the DVD drive and managed to reinstall Windows. However after I had restored some backed up files and was trying out a few things I decided to press Cntrl Alt Delete. It then told me WIndows was configuiring security settings or something along those lines in the windows loading screen type thing. After waiting a few good minutes I decided it was frozen and pressed the reset button. That sent me straight back to where I was about 2 weeks ago. Hrmm I really dont know whats wrong, is it my SSD, my mobo? Or am I just doing something horribly wrong?
m
0
l
February 14, 2012 4:45:11 AM

I dont know what to do right now. Is this in the wrong section? Should it be moved?
m
0
l
February 14, 2012 5:45:43 AM

You are fine here I think. I would also investigate the BIOS versions for the motherboard.

It could be anything at this point, including the motherboard itself.

Are you saying the SSD is no longer recognized in the BIOS? What is the AHCI mode set to?
m
0
l
February 14, 2012 3:12:15 PM

Should I record a video of what happens? It might convey to you better what exactly is going on or what I am doing wrong.
m
0
l
February 14, 2012 7:28:36 PM

Possibly. UBCD tends to be a little behind when it comes to new hardware, understandable given it's all shareware apps. You want to make sure your SSD is not incorrectly formatted or has a corrupted boot sector.

You say you installed on a HDD, and removed the SSD. Which came first? Was your SSD still connected when you installed? It just seems to me that the SSD is still the likely suspect.
m
0
l
February 15, 2012 3:53:32 AM

Here are some videos of what I get when I try to boot
http://www.youtube.com/watch?v=EdTFWBeGe0c
http://www.youtube.com/watch?v=RxLlVhw64Yk
http://www.youtube.com/watch?v=fRkSdIvygfM
http://www.youtube.com/watch?v=5nB9phweQIk
http://www.youtube.com/watch?v=QowSW5wVDEs
http://www.youtube.com/watch?v=YJVMDrNhi7U
Also to clarify the computer had the SSD installed as the boot drive and that was the only drive originally. It then randomly froze on me and wouldnt be recognized. I then ordered a HDD and tried to get an RMA on the SSD. I installed the HDD and I plugged the SSD into another place. I then was able to, after a few hours of messing around, reinstall Windows onto the SSD and get the HDD working as a secondary drive for storage. However just like the first freeze I had the first time I held down the power button to shut down the computer because I thought it was frozen. After that it left me back at square one again.
m
0
l
February 15, 2012 4:47:58 AM

Set the GSATA6 mode to AHCI and try again.
m
0
l
February 15, 2012 7:18:39 PM

Okay I will do that. I did a bit of research about the 2 modes and found that IDE is better for storage drives and is not hot swappable. Should I keep my HDD plugged into the GSATA port beside the SSD if i set it to AHCI?
Thanks for the help guys :) 
m
0
l
February 15, 2012 8:57:42 PM

Okay so I did as was told and now my HDD finally shows up. However it still takes a long time to get past the Gigabyte Logo screen and the SSD doesnt show up. Should I try plugging stuff in different places? SHould the SSD be plugged in somewhere else?
Thanks
m
0
l
February 15, 2012 9:52:22 PM

It still seems like the BIOS is spending a long time trying to identify that SSD. Will it take a long time to POST if you remove the SSD? or does it post faster?
m
0
l
February 16, 2012 3:21:01 AM

Okay I did as you said and it booted past POST at normal speed. I then plugged in the SSD in another SATA port and tried to boot. The computer seems to have recognized the SSD but then went into xpress recovery 2 mode, but then froze in that and wouldnt load any further than the first bit. I can get an RMA for the SSD, think I should or should I fool around more with it? When I get the new one I guess Im going to have to reinstall all the stuff onto it, or just try to move it all over, or maybe just use Intel Smart Cache.
Thanks for the help once again. :) 
m
0
l
February 16, 2012 3:40:18 AM

It sure seems like it's faulty. See if you can get any actual assistance from Sandisk before RMA.
m
0
l
February 16, 2012 3:47:57 AM

Okay. I have live chatted a few times and thats where I got the response about the firmware etc. I Have tried everything they suggested except try it on another computer because the only computer my family has that MIGHT be able to run the thing is my parents laptop that has a broken DVD drive. And even then there might be further incompatibilities.
Once again thank you very much for you all your help. Its very much appreciated.
m
0
l
February 16, 2012 4:02:31 AM

It's not uncommon for these types of drives to fail. Even mature Sandforce controllers like that one, and that's why I would still recommend Intel, Crucial, and Samsung first. They aren't immune but have a better record... both officially and anecdotally (if that's a real word).
Still, probably just bad luck.
m
0
l
!