Sign in with
Sign up | Sign in
Your question
Solved

Check system connections - Need Help

Last response: in Systems
Share
February 14, 2012 3:48:02 AM

Hi all,

This is my first system build.

I've built a new system with below configurations:

PSU: eXtreme Power Plus 460W (120mm fan)
CPU: intel core i5 2500K 3.3Ghz
MOBO: intel DH67CL
HDD: 1TB Seagate SATA 7200.12
Optical Drive: HP CD/DVD RW combo
RAM: Crosair DDR3 1333 4GB

The psu has a 20+4 pin connector, while my motherboard has a 24 pin connector.

Should i connect both 20 pins + the 4 pins to mobo mains ?

I haven't installed the RAM and when I start the PC, then should it sound a beep ? (if yes, it doesn't beep in my case)

Also, the smps fan and the rear panel fan do not start.
The standby light on the motherboard is glowing.

When only 20 pins are connected, The CPU fan rotates for a second and stops.
When all 24 pins are connected, nothing happens.

I just want to check if all the connections are proper. Please help.

regards,

Dhaval.
February 14, 2012 4:07:40 AM

zolton33 said:
http://www.tomshardware.co.uk/forum/269162-13-recommend...)

http://www.tomshardware.com/forum/262730-31-breadboardi...

A lot of info locked within those two links. Reading them should help you understand a lot as well help with the connections and trouble shooting plus you can then go at each of them at your own pace.


Hi,
thanks for the quick reply... but this info is quite overwhelming at this moment.. it would help me more if u can enlighten me with something more specific to my issue..

thanks again.
Related resources

Best solution

a b B Homebuilt system
February 14, 2012 4:10:30 AM
Share

You do realize there is a step by step illustrated build link in those right?

http://www.tomshardware.com/forum/274745-31-step-step-g...

And it says "This is my thread on how to build a PC step-by-step."

a b B Homebuilt system
February 14, 2012 5:32:20 AM

Hope every thing works out. I find it best that if its not working to throw out my ego (i mean ego as in thinking i know i did this this and this right so whats wrong) And start all over from the ground up following a guide and triple checking each step (over kill i know but i'm a perfectionist when i build my own systems and always believe that an ounce of prevention is worth a pound of the cure lol) So hope it all got fixed and your new killer gaming pc is ready to roar at last :) 
February 14, 2012 7:13:47 AM

Hi,
thanks for all the help.
One more question i have is

Any chances of the motherboard being damaged because of not using standoffs ?

I'll only get a chance to re-assemble my pc once i go back home.
February 15, 2012 2:45:47 AM

Hi,
Thanks for the adv.

I put in the stand-offs, re-installed all the cables and ....VOLA... !!
It came to life...
:) 
Thanks again
February 27, 2012 3:35:53 AM

Best answer selected by ddrajyaguru.
!