Sign in with
Sign up | Sign in
Your question

Win 7 sees but can't open XP folders

Last response: in Wireless Networking
Share
May 28, 2011 5:18:09 AM

Hi all,

I know this problem is all over. I've implemented/tested tons of suggestions--found here and other places. Still, Win 7 cannot open shared folders on XP...EXCEPT when XP is in safe mode(!) So, hope someone can kindly help.

- Win 7 is desktop system cabled to wireless router; XP is laptop connecting via wireless adapter
- I'm using HOME versions of both Win 7 and XP (alas)
- XP can open the shares on Win 7 system.
- Permissions on XP: Trying to get this to work, I have given full control of several folders to: everyone, Sjoy, and guest.
- Win 7 lists the shares in "Network", but when I try to open one I get msg: "\\LAPTOP\foldername is not accessible. You might not have permission..."

Other settings are listed below. As said, Win 7 can open shares when XP is in safe mode, which must be meaningful but I don't know what to do with this info.

Can someone please give me a hand before my head explodes? Thanks very much.

***OTHER SETTINGS***
- Workgroup on both systems = WORKGROUP
- Name and password is same on both
- "guest" is enabled on XP
- On Win 7, Network and sharing show: "Home network," Homegroup = Joined, Connections = Local Area Connection
Advanced sharing: Network discovery, file and printer sharing, public folder sharing, media streaming = ON,
File sharing connections = enable for devices that use 40 or 56 bit encryption
Password protected sharing = OFF
Homegroup connections = Allow Windows to manage (I've tried both ways)
- I've tested with all protection off on both systems
- Have uninstalled/reinstalled adapter

OH, also: I tried the Linux suggestion from Tinto Tech here: http://windowssecrets.com/forums/showthread.php/138042-...

Exactly the same under Linux as with Win 7, so problem clearly at XP end. But where?

More about : win sees open folders

May 28, 2011 6:38:52 AM


Try abandoning the Homegroup method and go through conventional networking, then disable the Windows 7 requirement for all computers in the network to be password protected..


m
0
l
May 28, 2011 5:58:35 PM

Hi and thanks. I've joined, unjoined Win 7 Homegroup many times. (Have "left" it again now.) When you say disable "requirement for all computers in the network to be password protected," you mean turn off "password protected sharing"? that is already off. Is there another password option somewhere? Any idea why sharing works when XP is in safe mode? Thanks.
m
0
l
Related resources
May 29, 2011 8:13:29 AM


It may work equally occasionally in Normal Mode if the cause is Windows 7's habit of only running the Browser Service every so often instead of every ten minutes. How long are the computers on and connected before the refusal to recognise takes place?


m
0
l
May 30, 2011 12:20:35 AM

Thanks for following up with me. I resolved the problem last night, using MSCONFIG to selectively choose services to run at XP startup. (As said, I figured it had to be something that didn't run in Safe Mode, although you raise an interesting point in your last post.) So...the culprits were from my backup software, Acronis True Image Home 10; specifically, the scheduler service and non-stop backup service. (I do schedule backups, but have never used the non-stop feature.) Anyway, as soon as I disabled those and rebooted, Win 7 opened XP folders and I leaped to my feet and cheered.

I figured the next step was to uninstall True Image. Since I use it regularly, I first searched for info about the offending services and found http://winhlp.com/node/40, which explains how increasing IRPStackSize can "fix" problems very similar to what I was having. So, I increased stack size (per instructs at site), re-enabled the services and voila! Now, assuming the stack size matter doesn't come back to bite me, I have two communicating computers and can keep my backup software.

Thanks again.
m
0
l
!